Moto G7 Power Ocean... Status of Beta or official builds

I want to know the status of the Moto G7 Power Beta or officials build.

But I must add some background. I installed the e-0.13-q-20201212-UNOFFICIAL-ocean build. For the first few days I did not use the phone calling feature phone (make calls). All non calling features seemed to work fine. When I did start placing voice calls the audio was extremely poor on both internal mic and Bluetooth (no usable).

I did some research and it seems it is actually the phones firmware that needs an update, I will be doing that tomorrow (cable not here now).

I believe Android is like any other PC device in that the firmware is underlying like bios is on a PC, am I correct?

So when installing e the firmware is intact or does e also write the firmware of the device? I don’t think so.

Anyway the unofficial build patch level is behind. Once I do the firmware update I will try the stock ROM and then unofficial build to test.

Does anyone know the status of the Moto G7 Power XT1955-x (2 in my case) official build or Beta? Anyone have thoughts on my above comments?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I’m interested to hear any updates you might have…

I never got around to re-installing the factory firmware but I could make some time this week. My carrier does not offer it directly (for download) so I will be using a similar factory firmware (same exact model XT1955-4). Once I have firmware installed I will install SIM, getting SIM active may take some work contacting carrier. Once the phone is on air I will see if there are new updates OTA for download.

One that is all done I will test that calling audio problem is fixed with factory firmware. If so then we will wait for E build, hopefully it will come soon.

I may need help put factory firmware back on phone because I think there was originally two portions. I will chime in when ready.

Oh wow that sounds way more involved than I expected! I just wondered if you’d found any other problems or given up… I jotted down a list of problems on xt1955-5 in some of the other convos about the moto g7 power: primarily screen not working during calls (so no number options or speaker)

Regardless, I’ll read whatever you post and help where I feel able… One thing, I think I’ve heard about firmware is that the firmware is a combination of your partition table and bootloader/recovery, which changed in wonky ways between android 8 and 10 (see an article by magisk’s Jon wu(?) at his github called "android booting shenanigans for an in depth explanation)

In you case it should be no problem, just make sure you do any firmware updates from Motorola before you install E.

My problem is now I have to roll back to stock factory, do the firmware update from Motorola. Once I have done the Motorola firmware updates I will test the phone by making calls to see audio problems are fixed. If not its probably a bad piece of hardware.

Then if all is well, install E once it supported either beta or official release…

1 Like


In other news, my screen has somehow fixed itself…!

And how the tests have gone? Was it software issue?

1 Like

OK so I tried going through the install instructions for android R for ocean and realized I can’t make sure my phone is on the latest stock ROM “same as version of /e/ I’m installing” because stock images only go up through android 10, i.e. Q not R.

Now should I just upgrade directly to /e/ r? Or instead flash the most up-to-date stock android Q and THEN to /e/ R?

I asked @manoj this question personally, then I realized this is probably helpful for anyone else trying this so maybe they could check this convo and get a quick tip.

Thanks all

From what I know, the latest stock Android for Moto G7 Power is Android 10. Motorola even with older models let to upgrade Android 7 to 8 and upgrade 8 to 9 was impossible. I don’t know why but this is what I noticed with Motorola phones.

I have installed /e/ on my Moto G7 Power two days ago and I would like to say big thank you for creating it for this model :smile:

What I noticed so far is:
:heavy_plus_sign: text messages work great
:heavy_plus_sign: phone calls work with no issue
:heavy_plus_sign: app installation is good as well
:heavy_plus_sign: bluetooth let my Mi Band to connect with Gadgetbridge as it should
:heavy_plus_sign: battery life is good (when I had Ubuntu Touch on other phone it changed it to battery drain)
:heavy_plus_sign: files app worked correctly with my pendrive with ending USB-C on one side

:heavy_minus_sign: it seems that weather app is stubborn enough to make slighty grey all written text options when I want to choose “use custom location” where I believe should show up option to choose city by hand
:heavy_minus_sign: when phone is on for few hours it happens that left side screen with latest apps in use and weather is a foggy screen with blurred background picture, after restarting the phone it comes back to normal
:heavy_minus_sign: I am not sure if “do not disturb mode” is working correctly as last night while being in this mode phone let sound to text message, where it shouldn’t according to not disturb mode

:wink: colour glitch I do not see as a big issue, as in settings it could be easily set with few clicks, and it is not that annoying sacrifice for having more secure phone os, for which Thank you again :heart:

1 Like

Do not disturb mode may be being overridden by another priority setting… Maybe search “priority” in settings…

1 Like

I need to check that out. Thank you :smile:

Update :smile: :angel:

I checked up how the battery charging goes, it is smooth and as usual (below 3 hours for full charge) however the phone turns itself on while with the changer plugged in. So charging phone being off does not work.
What is more, regarding to the system, Turbo charge does not show up. All this is just a notice, but does not disturb to use the phone at all.

Regarding Do not disturb mode it started to work somehow. Before I searched for Priority in settings. I believe that phone restart cured it :smile:

1 Like

Hi All,

I am revisiting this phone. While trying to revert to stock I half bricked it so to speak.

My original e ROM was the custom build (e-0.13-q-20201212-UNOFFICIAL-ocean). Now when I go to the file section I can only find the R build (recovery-e-0.19-r-20211207150338-dev-ocean).

I notice on Feb 9 Ana.117 mentions difficulty changing Android versions. Thanks for that :slight_smile:

Anyone have ideas on how to deal with this problem, or where older files are? I am thinking of recovering to the custom ROM (q) then work from there?

Let me know what you think… I can get to boot loader and find the phone as fastboot device. I have kept a copy from the information given with the command: fastboot getvar all

Thanks in advance jets

Wow, i might have some old stock and /e/ version files around somewhere… (Now i forgot which version of stock i used in between /e/13 and /e/19…i may have just flashed directly from older to newer.) Stock should be on (lolinet mirrors - firmware, software, iso etc.) and /e/13 should be around this motog7 power section …i can poke around if you don’t find it…

The problem for me recently has been not being able to locate a specific setting for VoLTE to get calls working now that 3g is out of commission (at least on AT&T and their MVNOs)

Any files that are older are worth a try. I think I need to figure out the Android version of e13.

Then again maybe the phone is bricked but you would think if I can find it with fastboot I should be able to recover it.

Oh wow so you’re trying to match /e/ 13 to its android analog… I don’t think it should be strictly necessary, but fwiw i went from android 10 (the most up to date as of april 2020) to /e/13. I didn’t go back to that 10 (which, iirc, was still the most up to date as of /e/19, or maybe i just couldn’t find the analog by then) before going to /e/19

OK so not matter what I would try I could not recover this phone. Then I got thinking and should have realized this was a problem much sooner; The phone would only power up if it was connected to a power supply, yet at the recovery screen (volume down-power button boot) said the battery was good.

The back of the phone was coming off anyway so I decided to inspect the battery. When I originally purchased the phone use, the back was swollen. I got a new back cover from Ebay and then peeled the old cover and cut some of the covering around the battery so I could install new back cover. I then proceeded to program the unofficial e 13.

The phone and battery were fine. Because the audio on the phone was poor (I think a Motorola firmware problem) I switched to another phone. When the official version for the phone came out I decided to give it another go. This is when I thought I had somehow bricked the phone.

So back to Ebay I went and found a battery. (I was going to post a picture but windows 10 just hijacked my photo viewer, I will post later after I fix that (sorry off topic).)

I installed the new battery and let it charge for a bit and low and behold it booted to e-recovery, seems it did install OK, I just could not boot to it with bad battery.

So if anyone has similar problems make sure the battery is good.

The only problem I have with the phone now (have not tested calls yet for audio but I suspect it will still be poor) is when I plug it in the phone boots the the recovery mode (like volume down-power button). I will work on fixing that now and post results later.

1 Like

So I tried re installing the e-19 OS but I get same results. When I plug in power cable phone boots to android recovery screen. I then enter e recovery and notice slot b is active. Does that sound right.

Any ideas on correcting this problem?

I think either slot could be used for recovery or boot, just depends which was active when you installed the firmware (installs to whatever slot is not recovery, iirc)
@Jets (tried editing into a response which didn’t work, so just @ mentioned you)