Motorola One 5g Ace (Kiev)

/e/ Team,
I am grateful for the community of privacy concerned developers who continue to make degoogled devices a priority. I had to buy a new phone recently, because my iPhones broke…and my old Androids were no longer supported by At&T. So, I got a Motorola One 5g Ace (AT&T prepaid version: XT2113-5) because it is cheap, really nice and 5g capable…which means AT&T shouldn’t be banning me from their network for a few years. I saw a forum on XDA where people have been able to get lineage os working on the T-Mobile varrient (same chipset). I really want to try e/OS. I like the lineage os, but I want to try your version. Please help me get it working. I have used ADB to remove most of the bloatware and the Google, aside from a handful of system apps that I can’t remove, because I don’t yet have root. So, I need root, and then I would love to have a build for this device. I am certain a bunch of budget conscious people would also love this device. It’s actually as good as my iPhone XS Max is on many levels, just no OLED screen, no stereo speakers, no wireless charging, but it has a better camera really and expandable storage and headphone jack, both face id and a fingerprint reader, oh and usb-c if you’re curious. Everyone go check this device out. It’s only $199 for the AT&T prepaid model (64gb ROM 4gb ram), which is carrier locked for 6 months, but the unlocked model (128gb ROM, 6gb ram) from Motorola is about $349 on sale. It’s the cheapest 5g phone I know of (aside from last year’s Motorola One 5g maybe) and I would love to get eOS running on this beast! Please help. Thank you!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


I’m interested in this, too. I bought the same phone, Motorola One 5G Ace and its got google all over it, inside and out and I cant stand it! My phone is unlocked. is there a custom ROM for this? Is anyone working on this? Lineage doesn’t have it. At least, my phone isn’t listed on their devices page.

I have been able to remove 99% of the bloatware and Google crap just using ADB debugging! lol :rofl: Here is the tutorial video on ADB debugging…

There are also developers working on root alover at XDA, but it takes a bit of work, which I just don’t have the focus to give it anymore… here’s a link to that thread…

So all we need is an /e/OS build! with moto actions please :pleading_face:

1 Like

Hey thanks for the encouraging word. I have to ask tho, if I let it update, will it put all that google crap back on there?

yes . try installing the NetGuard firewall app, from F-Droid (open source app market - just search the web for f-droid) and use NetGuard to block internet access for “AT&T Software Update”…this is actually three apps fyi… and then it shouldn’t update. Also, if you enable developer options, there is a setting inside that menu to disable automatic updates. i also turned that off. then you should be good to go. if you have any questions on a specific app, I can tell you if I deleted it or not, but some can not be deleted, but the tracking stuff is all from Google Play Services and Google Services Framework. Now if you use an app like gmail or YouTube that relies on google services, it will no longer work. because I use 2 factor authentication, the only replacement email app that I have found so far to be compatible with a gmail account is actually Microsoft outlook. (I know) It has calander access too. it’s not available on F-Droid, so when you install F-Droid, search for the Aurora Store app. that will let you install apps from the Google play store. you can login with your Google account on Aurora, but I didn’t because I am no longer using any of the apps I actually paid for (years ago). Also on F-Droid is a good (not great) substitute for the YouTube app called New Pipe. it will allow you to import your subscriptions from YouTube if you use Google’s take out option. you’ll need a web browser for that. I am using Duck Duck Go, which you can get on the playstore via aurora or on f-droid. also there are apps in F-Droid by a company called “simple mobile” that are great. try Simple Clock, Simple Calendar, Simple Notes, Simple Files, etc. there’s a whole suite of them. They all have orange colored logos on the f-droid store. on the Google play store they might look slightly different, but it’s the same app. I just prefer to get it from F-Droid as much as possible, then I know it’s not at all tied to google services. BTW there are two files apps on your phone by default…the google one and the system one. the system one is also a google app, but I haven’t tried deleting it, because I think it’s protected and it might make the phone crash. it’s just called “Files” (com. don’t delete it. might break stuff. lol :joy:

good luck!

1 Like

Holy hanna, you said a mouthful. Hey, over at the XDA-developer site on the link that you sent me, there was a comment left by someone who says his “unlocked” US version cant be rooted as the bootloader cannot be unlocked. I dont know how to check mine. that is, I dont know what ‘version’ cant be rooted. Mine is a Model Number (SKU) XT2113-2

However, as I understand it, I dont need to root anything if I’m just using ADB. is that right?

This is different that what I did with my moto G7 Plus when I put LineageOS on it. That was pretty straight forward with instructions, but I kind of feel like i’m just winging it on this new phone.

yep. you’re right about all of that. um so some people have gotten root on it anyway, but it’s way too complicated for what I am comfortable with at the moment. you don’t need root to do the ADB method of uninstalling the google apps, but you do need root to install a custom rom and remove some of the protected system apps. there aren’t currently any custom roms for this one yet, according to the xda forums. so I will wait until someone makes a good root method and just stick to the adb and make sure i don’t let it update anymore. probably it’s just very new, so when more people get it, they will maybe make a simpler root method… hopefully.:grin:

i ran into a little problem from the shell. “not installed for that user”??

pm uninstall -k --user 0 <— (google play store, i think)
response from this command was, “Failure [not installed for 0]”
Apparently, its a “system app”
I will try some of the others and see if any of them can be removed

where did I go wrong with my syntax?

I wish I knew which ones I shouldn’t uninstall because after I rebooted, it would hang at the big blue M during the boot. Took a lot of messing around to get the factory reset LOL I learned a couple things; I cant uninstall them all.

I uninstalled every google app from this list:
Google Apps Only

go back to xda. there is a debloat list … won’t let me post the link here but it shows up at the top of duck duck go if you type xda debloat Motorola one 5g Ace

webview, overlay, permission controller are system items. same for config and the latin input is your keyboard…which you don’t want to delete. lol :joy: at least not until you install a replacement… open board is pretty safe, but I don’t see a lot of language support for it.

these should be all safe to delete

Thats some pretty heavy duty stuff. I’m going to have to bag off for the night. I need a good dose of Rick and Morty before bedtime :cowboy_hat_face:

haha :joy: it’s just your list, but I cut off the ones I know of that you shouldn’t delete.

i removed or uninstalled as much stuff off my phone as it would allow me to do and reinstalled new dialer/texting/contacts app etc… I can send and receive texts and that seems to be okay, but my dialer doesn’t work. I cant phone out ! when I click the dialer, the app closes. Also, when I click on my firefox app, a google app pops up telling me I need to sign into google LOL. I have no idea what I’m doing. I have unleashed the beast. By the way; Happy Independence Day! :fireworks: :smiley:

I forgot to say that I was getting all my apps from apkpure and wasn’t paying attention to the version. I was downloading a bunch of Android 11 stuff and then later, while trying to install them, it would say some error and then I looked and my phone is Android 10. I thought my phone was pretty new, so I have no idea why it doesn’t have 11 on it. All of the apps that I used were “LineageOS” apps from APKPure, but the dialer app doesn’t seem to be doing anything. I wonder if I deleted too much.

no it’s just you’re trying to use Android 11 aps probably. if you deleted all that stuff in your list, the you deleted your phone app. if you only deleted the stuff in the edit I made for you, then you should still have your factory phone app … which is not going to send data to google as far as I can tell… i didn’t get any apps from apkpure, except for the google apps, because I ended up regoogling a couple times trying to figure things out because some things have to be installed or the phone will be slow. I’m still using gboard for example because it’s the safest keyboard app I can find with Korean language support. but anyway if you sseach for f-droid, then once you have that installed search in f-droid market for the aurora store, it will let you get apps from google play store without logging into google. this is safer in my opinion than apk pure, but I just wasn’t able to find the google aps like gsm and gfs on the play store when I needed them … and I didn’t want to do a factory reset since I had already set everything up. so yeah… this phone might never get android 11, because Motorola doesn’t typically release updates like that, but when they do, it has to go back through the carrier (since we have the AT&T version for example) and it will rebloat your phone anyway. so I imagine it’s best to wait until root is easier to achieve and then flash lineage os or this /e/ os, which I really want to try, but there isn’t support yet for this model. it’s still pretty new, so eventually we might get it. just have to debloat as much as we can and then wait.

1 Like

the main aps to get rid of is just the google play services (gsm) and google services framework (gsf) and the play store is android.vending those are the main ones, because without them, nothing else can communicate with google anyway.


Now that I have install Lineageos for this, it would be nice to get microg to make it more useful. I love the e/os on my sony XA2 Plus, but I can’t get a carrier to work correctly on it in the US. The Moto One Ace 5G is a great phone for a reasonable price.

Bump !