Need help installing ROM on Moto G Falcon

support

#1

Hello,

I have been trying to follow through the install guide.

I thought I had got to the point where I could flash the ROM on to the phone but (if memory serves me correct) I think it said there wasn’t enough space to put the ROM on the phone.

Can anyone help me with the install process please.

Right now when I start my phone I see a message ‘Warning Bootloader Unlocked’

Can anyone let me know what I need to do next?


#2

Can you boot into TWRP? To check do this:
With the device powered off, hold Volume Down + Power. On the next screen use Volume Down to scroll to recovery and then press Volume Up to select. If you can get into TWRP mode, continue with point Installing /e/ from custom recovery 4 here


#3

Thank you for your help @andrelam

If I follow your instructions I see the following …

Clicking on power and the volume down button I get to a screen with a black background and the text at the top says AP Fastboot Flash Mode

I then selected recovery Recovery and my phone changes to the Warning bootloader unlocked screen.

After this I see Green Android laying on his back with a red triangle with an ! in the middle of the triangle. Underneath read the words ‘No Command’.

Please can you let me know if what I have done is OK, and what I need to do next?

Thank you.


#4

In that case, TWRP is not installed. What you can do is this:
Do the same thing you did above, except going to Recovery. (you are in fastboot modus)

Follow the steps in the link “Installing a custom recovery 4” ( fastboot devices). Go futher form there. I guess something went wrong and TWRP is not installed.

Good luck


#5

@andrelam I am still having issues and hope you can advise me,


On the phone I have enabled USB Debugging and Developer mode

I can’t find or see an option to enable OEM

In the command line on my computer I run
‘adb reboot bootloader’

I get a black screen with the following message

AP Fast boot Mode (s)
Battery OK
Device UNLOCKED. Status Code 3
Status Mode: USB Connected

Then all the different boot options in a menu

Then under the menu I can see the words

Fastboot Reason: Reboot mode set to fastboot
USB Connected

Then I run
‘fastboot devices’

This shows a random set of numbers and letters then the word ‘Fastboot’

Then I run ‘cd desktop’ as the img file is on my desktop

Then I run
‘fastboot flash recovery twrp-3.3.0-0-falcon.img’

In the command prompt on my computer I see the following

target reported max download size of 536870912 bytes
sending ‘recovery’ (9606 KB)…
OKAY [ 0.453s]
writing ‘recovery’…
OKAY [ 0.312s]
finished. total time: 0.766s

Back on my phone I see the following output

cmd: getvar:partition-type recovery
cmd: getvar:max-download-size
cmd: download:00961800
cmd: flash:recovery
Missmatched partition size (recovery)

Then if I try to use the menu to go to ‘Recovery’

I get the message ‘Boot up failed’

Alternative method - Using SD Card

In addition to this I put the fastboot flash recovery twrp-3.3.0-0-falcon.img on the SD card on my phone

I went through the same process outlined above but when I go to Recovery menu I just get the picture of the green android laying on it’s back with a red triangle with an ! in the middle of the triangle. Underneath read the words ‘No Command’.

Please can you advise on what to try next?


#6

50

I think you did everything right, so it must be the OEM thing. Can you check again?