Network connections under /e/ 0.18

We have two devices now, I have a plussed FP3 and she has an FP3+, both on Android 10 with /e/ 0.18, configured very similar.

What I detect on both (!) of them in the last two or three weeks is that network connections seem to get somehow unstable. Not in every meaning, but some apps (especially the app stores) do not work correctly anymore after a few days.

This is weird. Especially because I cut my connections every evening (by flight mode) and restart them in the morning. I also change the wifi two times a day (company and at home). So all the connections themselves do never get older than a day.

The problem gets visible by surprisingly unsuccessful network operations. Suddenly Aurora can’t reach its repository anymore and turns the wheel forever. When I then try F-Droid it’s the same, can’t connect. Yesterday it was AndStatus (a Twitter client) which could not send anymore. But note: this happens while other apps (for instance Signal or FairEmail) do still work, so I guess it affects only some network protocols or ports or security layers. When this happens the situation is never solved by itself. You must reboot manually.

I never noticed this with previous versions of /e/. Before /e/ 0.18 I could run my device for 30 days or so without a single reboot. Now I must reboot every four or five days because of malfunction.

Has anyone else also noticed this?


I’ve a similar issue, with twidere, aurora and, sometimes, browser. But, i have this issue with the wifi connections and not with data connection.

I have a GS290 with 0.18.

Yes, sure, also on wifi. My app stores run on wifi only. I don’t think the problem is related to a special kind of connection. As I said, the connections are renewed every few hours, at least once a day. It’s somehow above them.

Do you use NetGuard? Is that part of the problem?

No, not Neguard and i have the issue with or without shelter.

The problem seems to be related to the automatic (re)connection to a known wifi network.

When the device was connected to a wifi network and leaves it the current connection will be broken. The wifi symbol disappears. – When the device reaches later again a known wifi network (the same or another) the connection should be (re)established automatically. The wifi symbol is shown again. Everything looks good but indeed it isn’t reliable especially for app stores and streaming apps.

A workaround is then to switch wifi connections manually off and on again in the new network, then it works until you leave it again.


Yes, i have the same solution… For the moment …i hope

Did you try to disable the MAC address randomization (WiFi network advanced settings) ?

I can’t find this option

It may be somewhere else, search “MAC” in Settings :wink:

Developer options, if these are active

Yeah, but what does the user lose if he deactivates MAC address randomization? The device is better recognizable, isn’t it? How often is the MAC address randomized?

I notice that your post starts with

We have two devices

I am thinking that each phone has to be recognisable by your router! I have had issues where I start a Cubieboard with different OS on different cards same day. My router struggles to sort out identities, but does often learn or tolerate two identities in due course, after clearing its memory and ideally give each instance an alias in the router.

I think I would try to drop the MAC randomisation on both phones, clear the memory on the router, test, then see if you can switch on randomisation one at a time!

1 Like

It is a paramater which is disabled by default. Also the developer options.
Thus, this cannot be a issue by default.

To your question:
Yes, your device is trackable over all the SSIDs and WLANs you are using and roaming.

but honestly the use case where this can be exploited and seriously seen as a threat is already very rare
Not for otto normal users
in rare cases where it plays a role you can turn it on. otherwise it will definitely cause more problems than it brings benefits

Sounds all easy to comprehend. But I also can’t find the option in my developer options. I also can’t search for it, I get three matches for “mac” but they all are not the right one. A search for “random” leads to no result at all. (0.19 from today)

So I guess I never changed the default on both devices.

Maybe it is hardware limited
WLAN NIC or driver. Don’t know.
I have it on a Nexus5

But you’re right.
If it is not available then it is not activated. because it is not enabled by default.

I made an issue now. I had this that morning on my brand new updated 0.19. Something is not good anymore.


Luckily I’m not the only one with this problem. The Wifi-connection to my home network is not reestablished/reactivated either. I read through the Github page of Irrlicht’s issue and my conclusion is that I have to wait for an update of /e/OS, maybe R.
This is not a minor issue, since a stable Wifi-connection is one of the most important things that one needs on an Android OS.
—By the way, it’s 18 months since the last comment. So, can one of you tell me if updating solved the issue, or something else did the trick?

Yeah, but I must say, these problems seem to be history now. At least since 1.8 (which brought also S on my FP3) I haven’t seen this a single time anymore and my device runs now indeed without a single reboot from OS update to OS update.

Thanks for the quick reply. Good to see that it’s solved. I recently put /e/OS om my phone so I would expect to have a recent version. I will check the version I have after my phone gets back from servicing.