Nexus 5X on Q: best way to use /e?


I own a Neus 5X, that currently runs on an inofficial PixelExperience (10.x), and want to use /e/ on the device - to “de-google”.

The first try almost bricked the phone (Bootloop) and I went back to PE - which saved it. That’s how I found out about “going back in the android version might brick your phone”.

what’s the best way to get /e/ on my Nexus?

a) going back to stock, and using current /e/ image?

b) wait a little until /e/ upgrades the android-version (IF)?

If a) is the way to go - is there a good step-by-step-manual on how to go back to stockrom for the 5X? (did a search, only things I found were for the Nexus 5 - not sure if these steps apply to the 5X, too) (found a tutorial - now Q is “will Q be available soon, or should i revert to stock?”)

Thanks for your help!

I don’t see /e/ being supported on Q until Q is supported by LineageOS, and right now there’s no more official support for our device by LineageOS (15.1 are not supported anymore, although its maintainer continues to share unofficial builds with security fixes, and there’s only unofficial builds for 17.1 which were not stable enough when I tried them last year).

So I suggest you reinstall the stock OS if you want to have a chance to try /e/ OS on your device now rather than probably never if you wait for a Q build :slight_smile:

PS: Apparently a recent a update of LineageOS 17.1 has fixed a critical issue with the GPS, I’ll try that build again later this year and if it’s stable enough I may release an unofficial /e/ OS based on it.

1 Like

Yeah, that was my initial “drive” to look out for other images: missing Lineage-Support…

Think you’re right. 17.1 (or PixelExperience 10) runs pretty smooth (didn’t run into problems), …but I think I’ll switch to /e/ now…

Thanks :slight_smile:

(never gone back to stock before - hope I’ll not fu…k that up :wink:

1 Like

The way that worked for me was flashing latest stock Google OS and then installing /e/.

I found an issue when using newer versions of android custom roms and then dropping back to lineage official and /e/ official without flashing stock first.

My Nexus runs /e/ now :slight_smile:

I ran into some issues returning to stockROM though; had to get the newest ADB/Fastboot-Framework form the google-page, the version in the LinuxMint-Repository seems to be outdated. With the newest one, it worked.

Still trying to find my way around /e/ (long time since i worked with Android 8-base :wink: but looks great so far - Q is will the apps I need be working via MicroG; if yes, I have a new old daily driver :wink:

(only issue I ran into - where could I report this? - …mobile data was active until deactivation. This is rather common in ALL roms, but very annoying if you use a prepaid-Sim in the phone. Since /e/ is focussed on privacy, it would also be better to have an “offline until the user decides otherwhise”-policy, at least: no open data-connection until the user decided to use WLAN, mobile-data, or both…)