No media audio from speaker on Fairphone 3+

I’ve been using /e/OS with a Fairphone 3+ without too many issues for a while, but suddenly all media audio has stopped playing from the device itself, unless I connected to headphones.

Alarms are still playing OK through the phone though, so that rules out a hardware issue with the speaker itself. But there’s no sound playing from web browsers or media apps such as the built-in music app.

All the volume sliders are up, and I can’t think of any other settings I could have changed accidentally to cause this to happen. It must be a software bug? Please could anyone help?

I’m running /e/OS 0.17-20210621120946 but it was the same with /e/OS 0.16 before I upgraded too.

You might try to start in Safemode to rule out an installed app to cause this problem.


Thank you @ff2u, just tried safe mode and it’s still the same - no audio from the default Music app.

I realised since my original post though that it could be a hardware issue after all - as the loudspeaker is a separate component (source: iFixit). Presumably alarms use the loudspeaker as opposed to the regular speaker?

I also found that I can’t hear people on calls - unless I switch speakerphone on. Again, presumably that switches which speaker is used for the audio?

So next step I’ll buy a new speaker module from the Fairphone store and give that a try!

You may do this.
You might also check if there’s a Fairphone Angel near you for trying to switch the module for testing.
Or you might open a ticket with Fairphone support as I assume your device is still under warranty.

Btw.: Did you try to test the speaker via the test menu ( Entering *#*#66#*#* in the dial app to show testing menu)?

Thanks @ff2u , no angels near me unfortunately, but I re-read the iFixit guide and it looks like I got confused by the term ‘loudspeaker’ and that’s the regular, main speaker module after all…

Also, since I can’t hear people on calls, unless I switch on the speakerphone mode, that must mean I’m not getting audio out from the ''earpiece speaker" in the top module either, which does make it seem unlikely again that it’s a hardware issue as it would have to be affecting two components…

I just tried to enable the test menu by entering the keys in the dial app as you mentioned and as I found on the Fairphone support site too, but it didn’t appear to do anything except just blank out the characters as soon as I’d typed the last one. I guess the Service Menu should be immediately visible somewhere?

Thanks again for your help.

Just a heads-up if anyone else is going to try restarting the phone in safe mode and in case noone has reported this bug already… it lost most of my apps folders - all the ones that disappeared in safe mode (i.e. only had non-default apps inside) were still missing after I restarted again in regular mode. (Wasn’t a big deal for me to create them again though - it still had the apps there, I just had to re-arrange them).

Sounds like Service Menu isn’t implemented in /e/OS?

Ok, sorry for that

and that

I’ll add the warning when recommending safe mode next time resp. I’ll not recommend Service
Menu for /e/OS user again. :man_shrugging: