No new Easy Installer instructions/steps after 'Do not install' TWRP

To try to answer your final question one really needs to study the whole log. What did Easy Installer manage to do and where did it first fail?

@aibed and @siggi, somebody gave me another phone and (stupid as i am) i tried it with this phone again and… same result.
All steps went ok but after the last step: ‘do not install’ nothing happens anymore either on the phone or on my computer.
Did i kill the second???
I hope this is the link too the log: hastebin
I hope somebody can help me out or is /e/ to complicated for dummies like me?

Hi @frisober, please can you describe a bit more fully where you saw ‘do not install’. Was it on the device or on the PC? Did exactly the same thing happen on the second phone? Was this a second SM-G950F (dreamlte)?

Your log shows

Uploading RECOVERY
RECOVERY upload successful

but it is not clear to me what is happening after that point.

Were you able to tell if the installed Recovery was usable? (That is to attempt a manual install). And / or, in what state are the phones now?

Know your hardware - Samsung

Hi Pierom Yes it is a G950F. I just followed all the steps (in Dutch because I m dutch), in TWRP I ‘wiped’, ‘formatted data’, then 3x back, ‘Reboot’, ‘Power off’ and then ‘Do not install’ and after that nothing happened anymore, neither on the pc or on the phone. Luckily this time I could start the phone in Android because the other phone isn’t on Android but also not on /e/. It is not reacting anymore, just starting up and shutting off after just saying Galaxy S8, endlessly. If I press vol up, Bixby and power I get the blue/green download screen but I have no idea what step to take. Easy installer does not see him anymore. So, what to do??? As I said maybe it is just to complicated for me and do you need more skills even though it seems easy with easy installer.

Easy Installer does not ask you to do any of the things you describe, in my experience. Are you seeing this on your PC or on your phone.

Samsung is quite good at protecting your devices! Let’s try to fix one device at a time.

Because your device is new and witout installed apps, try first a factory reset
(In TWRP–>wipe)
Then, reboot to system.

@aibd, What I described was what I saw on my PC (see the png).
The 2e phone is running on Android so no problem (if you want to keep it like that) and the other is not responding at all apart from what I described.
@Piero, I don’t know how I could do that because it only starts and shuts down or the green/blue download screen that tells me it is Downloading (what???) and only gives the choice to press vol up and start to restartm so I’m in a loop with it.

@frisober Is your Samsung set to “Taal = Nederlands”?

Hello all,

In the following, I describe the entire procedure until the installation is aborted:

  1. Start Easy-Installer

  2. Introductory notes

  3. Connect the S8 to the PC via USB cable.

  4. Activate developer options (part 1)

  5. Activate developer options (part 2)

  6. Activate USB file transfer

  7. Remove registered accounts

Cannot be performed because no accounts were created during setup.

created during setup.

  1. Device detection

After a short time, the message appears: Your SM_G950F is compatible with "/e/OS

  1. Downloading “/e/OS” and the necessary files

After some time the message appears: The download was successful, you can now install “/e/OS” on your smartphone. 10.

  1. Installation

I. OEM Unlocking

a. Open Settings

b. Open Developer Option

c. Activate OEM unlocking

d. Switch off phone

e. Switch on device with On + Bixby + Volume down to enter download mode.

f. Accept warning with volume up

g. The recovery programme is installed on the S8.

II. Start in recovery mode

a. Switch off the S8 with On + Bixby + Volume down.

b. Restart S8 with On + Bixby + Volume up. The Teamwin screen appears

III. Format data and switch off the device

a. Tap on "Wipe

b. Tap on "Format Data

c. Write "Yes

d. Confirm (S8 reports: “Data Format Complete Successfull”)

e. Tap 3 times on Back (Not on “Back” in the TWRP programme but on the Back button of S8).

f. Tap on "Reboot

g. Tap on "Power Off

h. Tap on “Do not install”.


S8 switches off and nothing happens. The Easy Installer offers no possibility to continue.

The log shows the entry: “No interface to load”.

I switch S8 on with the “On” button. After some time, the device can be set up again.

@aibd: The entire log file is 950 lines long. Can I already put this in a thread? It will be long. Or is there another possibility?

Translated with DeepL Translate: The world's most accurate translator (free version)

Wrong advise from easy installer,
At this point you’d better choose " reboot to recovery"
and continue to the installation process :

  1. Wipe the needed partitions (advanced wipe)
    /system, /data, /cache, and /davilk-art-cache,
  2. Install the
  3. Reboot to system

@piero, that’s funny because the installer is very clear up till this last step…
Are you very sure and why isn’t it altered if it is a bug? Not that I doubt you but loosing another phone… then I’d rather stay with our ‘friend’ Google
What siggi writes is exactly what happened to me two times and luckily with the second phone I found it still in Android but the first phone is lost I suppose.

Nearly impossible with a Samsung ! . .

@piero, Anyhow I have not the slightest clue how to revive it.

Using Odin (windows) or less easy heimdall (mac, linux)
You can restore samsung software and install TWRP,
You can follow the illustrated guide i linked in previous post

But in your case,

If it don’t boot into /e/,

you just need to finish the install process starting at step (7) or (8)

  1. Wipe the needed partitions (advanced wipe)
    /system, /data, /cache, and /davilk-art-cache,
  2. Install the (already downloaded by the easy installer)
  3. Reboot to system

I am going to have to make a guess here! You are both from and using the Dutch language, perhaps there is a translation error in Easy Installer.

Do you see a button “Do not install” within TWRP at this point? What are you able to do at this point?

The “How to troubleshoot Easy Installer” link earlier includes a link to which is the best way to share your log.

The Easy Installer offers no possibility to continue.

I can see that this would be the case!

Maybe it has never been reported.

Just to be clear, the phone returns to operational Samsung/Android?

That does seem like a loop … but please can you check out this video … I have to say I am not certain what state your phone is in, but if TWRP was uploaded successfully you would be able to get to TWRP in the same way seen in the video.

There is more information on this in a link I already gave Know your hardware - Samsung

In Post # 2 I mentioned “Keep read only” I just want to add this image, purely as a guess, in case it throws any light on a possible translation issue.

@piero, as you predicted correctly I can access TWRP but when I wipe /system, /data, /cache, and /davilk-art-cache and then go to install I see no I downloaded I myself and put it in the internal storage. After choosing installing a lot happens and after restart I see e with a jumping ball but… nothing further. In the end the phone returns to TWRP. What do I do wrong? You see I’m a dummie.

@piero, I forgot to mention that when doing what I described I got the message that the ‘zip verification signature failed’ so I guess something is missing but what???

Hi @frisober if I said something that caused offense I apologise. I will persist and try to help! :blush:

I think the most likely reason that you see the bouncing e, but that /e/ never fully opens is that the wipe of the data partition did not happen correctly. (Your Easy Installer instructions had you Power off - that itself was wrong not in the regular method.)

I suggest you review the manual install instructions

Installing /e/ from recovery

and try again.

And you must uncheck the .zip signature verification box when you see it in TWRP.

Notice that I am using TWRP from the device and not from the PC as written in the instructions.

Also described here : Install the image of /e/OS on the ROM of your Samsung device without computer, with TWRP using the SDcard method

@aibd, that solved it! Thanks! Now it is running. I have some more questions like how to install Signal but I hope I’ll find that somewhere.