OnePlus - Nord - avicci - Documentation Suggestions

Great news! Go to Settings > About phone > Android version > tap for /e/ version, long press copy to clipboard.
Also foot of About phone > Build number. Also, long press copy to clipboard.

Great news indeed!
It’s Android 10.
Build number: 10 QQ3A. 200805.001 eng.root.20211027.184332 dev-keys,stable-release

Probably I did not upgrade to R, although this seems not very likely.
I am amazed that formatting /after/ flashing did the trick.

Thanks a ton for your help!

1 Like

@Manoj Hi, better provide no installation instruction than a wrong one. Can you please update the instruction or at least write on top that it’s wrong!!!

  1. Problem with not recognized driver under windows: [Guide] Fix Device not showing up in Fastboot Mode (windows 10) | XDA Forums
  2. There is no TWRP for OnePlus Nord ?
  3. Is it a must to downgrade to android 10 ?

I guess point 6 is the TWRP recovery?
Hours later: found an inofficial TWRP, wipe was ok, but advanced wipe has no cache and system option? I have only the following options:
Dalvik/Art Cache
Internal Storage
USB Storage
Isn’t there a way to do this with fastboot commands instead of TWRP?
C:\fastb>fastboot erase cache
Erasing ‘cache’ FAILED (remote: ‘Check device console.’)
Same with system and nothing on console

Hi, I’ve just gone through the steps for the OnePlus Nord - “avicii”.

When starting the phone, I am getting an error stating that the OEM is unlocked.

I tried to lock it again and received an error:

Your device is corrupt. It can’t be trusted and will not boot. Visit this link on another device:

The device was working perfectly aside from the OEM warning before locking the bootloader.

Is there a step missing in the instructions to lock the bootloader again?

Hi @wadejbeckett welcome to the /e/ forum. Sorry if you do not get a helpful response on this thread. Locking after /e/ install is not possible on this device, I think!

Sadly, many devices get that annoying message - some just regard this as a “badge” for “escaping”!

This does not help you right now :blush:

If you do not get a solution feel free to ask on a new thread.


Hello! the picture from Info about OnePlus Nord - avicii suggests it has one fron camera when in reality it has two, I might we wrong but seems like that :slight_smile:

Thanks @Guillermoto will pass this info on to the Graphic designer to update.

  1. I notice a slight misleading documentation of the links, both developer and stable links have the following title/heading:

/e/ ROM latest dev build downloads

should say

/e/ ROM latest stable build downloads

yet links are as follows;

  1. I just installed e on a Nord AC2001 last night and the steps were not exactly clear.

At step 13 I got response: Script succeeded result was [0.0]

Again minor but it kind of scared me sitting there for 10 minutes before I realized I could reboot.

This issue has been reported a couple of days back with the build team. Will check for an update.

1 Like

On the step: “Booting a custom recovery using fastboot”,
#5 says: " Flash a recovery image onto your device by typing fastboot flash recovery recoveryfilename.img Replace the recoveryfilename with the name of the recovery image you downloaded in the previous section"

This could use some clarification as every time Ive tried it, it doesnt work and says “cannot load…”

Once you have downloaded the recovery image, you run the command from inside the folder where you downloaded it …this on an adb enabled PC with the phone being detected by adb
The command should be something like

fastboot flash recovery recovery-e-1.1-q-20220629200240-dev-avicii.img

yes this is the exact part Im stuck at.
phone is not detected by adb when in recovery mode.
when running normally, it shows and when in recovery, it shows in fastboot, just not adb :confused:

ok, documentation suggestions!

  1. in order to open cmd prompt in the proper location:
    press “shift+right click” then, open powershell

  2. for the load recovery step; use: shift+right click to open a powershell inside the folder where the recovery file is and then drag and drop the file into the powershell instead of manually typing the name

I tried many times to type it manually and drag and drop worked first time


Following the installation instructions on a device with OxygenOS 12 will brick the device! The following error message appears after flashing the custom recovery and trying to boot to the recovery or system:
"The current image(boot/recovery) have been destroyed and can not boot."
The same happens after flashing other custom recovery images. (TWRP, PixelExperience)

I did the following to get OxygenOS 12 working again:

  • Download the latest OxygenOS 12 image for the correct phone model from here (under Signed flashable zips)
  • Use the Firmware Extractor to extract the img files from the downloaded file
  • Reboot the phone into fastboot mode by holding Volume up + Volume down + Power
  • Flash the extracted recovery.img: fastboot flash recovery recovery.img
  • Reboot the phone

To downgrade to OxygenOS 11:

  • Download the downgrade zip for the correct phone model from the page linked above (under Downgrade zips, version
  • Copy the zip file to the phone
  • Go to system settings → About device → Up to date (Official version) → Dots (top right) → Local install
  • Select the zip file
  • If the verification fails you downloaded a file for the wrong phone model
  • Continue the installation
  • After rebooting to OxygenOS 11 you can continue with the /e/OS installation

Please edit the instructions.


Hi @mat1 welcome to the /e/ forum. Good catch and fix.

@Manoj, looking through the command line install instructions for Nord (and quickly a few other pages which I am fairly familiar with) the standard “Red box” Warnings / Cautions sections seem to be missing in a widespread manner.

Some of the device pages, especially FP3, FP4 and avicci are not based on templates. Most of them are written by the device maintainers.
Let me know if any warnings need to be added and will have them added.

I have searched quickly from the top of the Supported Devices list,

as off topic for Nord here is a shortlist.

Looking for the “Red box” Warning / Caution expected at top of page re ensuring correct Android version on which to install /e/

ASUS obiwan – missing
ASUS Z01R – missing
ASUS sake – missing
BQ bardock – missing
BQ bardockpro – missing
Essential mata – missing
Fairphone FP2 – missing
Fairphone FP3 – missing
Fairphone FP4 – special red box only
Gigaset GS290 – a special platform-tools caution only
Google mako – missing
HTC pme – special unlock warning only.
HTC m8 – special unlock warning only.
Motorola racer – missing
OnePlus nord – missing
OnePlus bacon – missing
Samsung a3xelte – missing
Samsung crownlte – missing
Samsung starlte – missing
SHIFT axolotl – missing
Sony kirin – missing
Teracube 2e – special serial number caution
Xiaomi monet – missing

I will look at the documentation pages later and see if I can find the commit that might have made the change, I think it will be quite recent.

Edit. @Manoj, in the time available I did not recognise a responsible commit. I will perhaps Report an issue later unless done or solved by someone else.


Section "Steps to install /e/OS from recovery" in step 9 states

adb sideload

Replace with the name of the /e/OS file you downloaded in the previous section

If I understand correctly, what is meant here is the e-[version number]-r-… file downloaded in “Downloads for the avicii” section (where the zip resides with the .img file).

I would like to suggest making it clearer that the e-… is the correct zip (it can be confused with the copy-partition-zip from the previous section).

Furthermore, I would like to propose the install page contains a hint that the Android (OxygenOS) 10 version should be present on the Oneplus Nord, i.e. not version 12, because of the issues @mat1 mentioned earlier.

Thank you very much, looking forward to install /e/OS on my Oneplus Nord :slight_smile: