Oneplus X fails to sideload ROM despite following guide

So I’ve spent the day trying to install /e/ onto my Oneplus X, and after frustratingly following the not-so-beginner-friendly guide, the sideload always fails on my device.

I followed the official guide exactly, filling in the gaps with my own research when the instructions didn’t work. I believe that by far the biggest improvement that could be made to the guide would be steps explaining how to confirm each step has been completed correctly.

However having followed the guide now perfectly, the ROM always fails to sideload. I get the Status 7 Error.

Starting ADB sideload feature…
Installing zip file ‘/sideload/’
Unmounting System…
Comparing TZ version TZ.BF.2.0-2.0137 to TZ.BF.2.0-2.0137
Target: OnePlus/OnePlus/OnePlus:5.1.1/LMY47V/1441677661:user/release-keys
detected filesystem ext4 for /dev/block/platform/msm_sdcc.1/by-name/system
Patching system image unconditionally…
E1001: Failed to update system image.
Updater process ended with Error: 7

I’ve tried remving the assertion lines from the ROM, as that’s what people most commonly present as a fix, but it made no difference.

So yeah, I’m really stuck

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

A lot of device a running into this sideload issue. I prefer:

  1. format data with twrp (wipe is not enough)
  2. reboot into TWRP – it’s urgend
  3. wipe system and Davlik, cache
  4. copy on internal storage of your device with PC file manager
  5. flash with twrp install menu
  6. reboot
  7. be happy
1 Like

Let me add the standard clean flash method to the documentation as @harvey186 mentions in his response . This install by sideload comes from the LineageOS wiki documents on which we have based our documentation as mentioned in the credits. It works when you already have a /e/ ROM and want to upgrade the build . Also retains user data. That being said for a OS change it is always better to clean install after wiping - system dalvik and cache.
Just flashed a OnePlus 7 pro Guacomole over the week with /e/ and with the clean flash method it works perfectly. The phone was stuck at the boot screen due to an incorrect stock ROM flash attempt. The first - flash - TWRP part is important though for all devices.

Hello Again,

I have just tried again there now following the steps provided by @harvey186 and I am still getting error no. 7

When you say System, Dalvik and cache what options in the TWRP menu does that entail?

Options are:
-Dalvik / ART Cache
-Internal Storage
-Micro SD Card

:white_check_mark: -Dalvik / ART Cache
:white_check_mark: -System
-Internal Storage
:white_check_mark: -Cache
-Micro SD Card

But Error: 7 (sometimes) happens when the original system is not the same (especially higher than) Android version as the proposed_to_install /e/ ROM !