Pixel 4 5G bramble - Install Trouble - Recovery not working

Hi everyone,

Slowly discovering the forum and the entire E-Foundation concept and very excited to try this out.

I am having some trouble though.

I’ve just acquired a second hand Pixel4 5G bramble It’s running android 13, no google accounts linked to it as it’s a fresh start.

I’ve been through the process of the easy installer. The phone was detected, unlocked, usb debugged, oem openned, the download occurred, I got through to the fastboot unlock process and for some reason when I trigger the recovery mode, it loops over and over with no screen appearing to format the phone and install the new OS (and no option to format using the standard formating)

I tried troubleshooting myself, and got Android 13 ROM back on with correct version for Pixel 4 5G bramble provided by Google.

I then went through the entire manual process (without easy install) and after the flash recovery the phone doesn’t boot, I get a “No Command” screen with no options or choices. All I could do is flash stock another google Pixel4 image again.

So I’m really not sure what the issue is.

I though maybe the slots where the problem but the Google install fills them all. I tried forcing slot A and then B but no results and have done both processes (easy install & manual install 3 times each).

Any ideas ? Has anyone else had this issue ?

Thx !

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Your device needs to be on stock android 12 beforr flashing eos-s

I would advise getting stock 12 on both slots now, before installing e

Right ! Thanks @chrisrg !

I’ll try that later ! I did actually give a go in Android 11 on one of my attempts (forgot to mention) with no better result.

I’ll let you know, :wink:

I dont know anything about easy installer, but if you do cli install: follow the lineage install guide for getting a recovery temporarily onto device and use the oldest vendor boot img from the list.

By the way, the “no command” screen is the landing screen for stock recovery. Hold pwr button whilst quick tap on vol up to acces the menu. Hopefully yu won’t see it again!

As a reference, I bought a Pixel 4a with Android 13 allready on it. My goal was R stable. So I flashed with Edge Browser (Google has some flashtool) one of the first Android 11 Versions. Then I installed with Easy Installer (V1.5 R stable) and this weekend OTA with 1.6 came. Everything works fine. I hope next OTA works also like a charm.

I am experiencing a similar issue, but do not have the technical experience to reinstall android. I, as you, installed with the easy installer and reached the recovery installation step only to succumb to a boot loop from my unlocked boot loader screen to the Google screen. This goes on repeat ad infinitum. I attempted to install recovery through the terminal and receive this message: FAILED (remote: Not allowed to flash (recovery)). I am stuck and cannot figure out what to do from here. If anyone has advice for either getting e/os recovery on to this device, or somehow restoring it back to Android 11, I would be very grateful for the assistance.

You could try Android Flash Tool

Thank you! That worked perfectly and it was very easy. I appreciate your help.

1 Like

Thank you @chrisrg for the response and the “no command screen” tip !

I followed your advice and installed an Android stock 12, all went well for that part.

I then tried the e.foundation S 1.6 OS (for pixel 4 5G) which led me here :

So I tried with several older EOS builds going back to 1.2 and I don’t even get to the recovery stage.

All of this was using ADB manually (not easy installer).

Could you develop what you’re talking about when you say

“follow the lineage install guide for getting a recovery temporarily onto device and use the oldest vendor boot img from the list.”

I’m wondering if I’m misunderstanding this point.

I’ll try this using the same steps you did @mihi :wink: Thanks

Sorry guys took me ages to get back to you.

I retried the process using all your tips using previous version. Turns out that worked. Thank you all !

1 Like