Pixel 4a downgrade

Hi, I’m tryng to install /e/ on a Pixel 4a. The device is on Android 13 so I know I have to downgrade it to android 11. I read I could use Android Flash Tool but it gets stuck every time I try to use it so I want to do it manually.
My phone is already in fastboot mode but I don’t know which image I should flash.
From https://developers.google.com/android/images I’ve downloaded the full OTA image for RQ3A.211001.001. Is it the correct file to flash? Or do I need the factory image? I can’t find it. Now I have two files but none is a .img (as the one I’ve installed on an other device that now has /e/). They’re .bin and .pb files.
Is there a guide to follow to downgrade? I’ve read some online but they seem quite confusing…
Sorry, I’m a noob on these things, and thank you in advance for your replies. And sorry for having deleted and modified this post some times but I’m trying to understand this procedure.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

The method you are attempting is more expert than I can help with !

Would it help to review your progress with Android Flash Tool ?

One possibility is that your browser does not like the tool, where does the process fail ?

There is an alternative Pixel 4a - downgrade CalyxOS (A13) to eOS 1.9 - #6 by Gianna

Advice may differ for which version of /e/ you want.
So follow /e/ install guide to decide how you’re going to do it and therefore which stock android version you are going to need.

Downgrading from stock13 to stock 11 by flashing with an install script I hope is possible, I’ve not tried recently. A while back I did flash a pixel 5 from stock 12 back to stock 11 OK, if my notes are to be trusted!

The "factory images " page you have linked in your post is the correct page forwhat you want to do, and that is the correct version you describe.

The “full ota images” are a separate web page and they are for sideloading from stock recovery. Not sure if that would work for downgrading.

Unlocking bootloader is required to flash the factory images and the instructions of how to do it (and the rest of the procedure) are at the top of the page you have linked.

1 Like

Thanks for the answer. I tried it with Firefox (not supported), Chromium (it gave the error the phone was busy in some process), so I tried to install the flatpack of Edge (officially supported) and the process went smoothly till after ending the downloading of the image, then it crashed suggesting me to try to close and re-open the browser (tried it some times and the result was the same).
I solved the problem temporarly installing Calyx Os that it’s on Android 13, but I will surely install /e/ also on this device in the future (moreover the calyx os support for Pixel 4 is only till 02/2024)

Thanks, I had unlocked the bootloader. The page is correct but there are no images at all: I’ve also watched some video tutorials and something has changed from the past. There are the instruction but scrolling the page I only found an hyperlink to the full ota images.

Well … you do not get to see the full contents of the page until you Acknowledge at the foot of the “primary” page, only then is displayed “all devices” including (among many) https://developers.google.com/android/images#sunfish

1 Like

Oh, it was there… Thank you very much! I had read all the page and didn’t find it, my fault.

Here you will find the files to download AND a step by step explanation of how to flash it using fastboot or online tool :


1 Like