Pixel 4a: /e/ OS GPS issues

Hello everyone!
I was trying to install /e/ OS on my Pixel 4A, and, after few issues with the installation, I managed to do it:
first of all, I installed stock android 11, then used the Easy Installer to install /e/ OS r.
The installation went well but the location services don’t work.

I installed GPS Test from the store, to check if it’s working, and it isn’t able to retrieve any latitude/longitude information.

I looked into the community and already tried to clean wifi/bluetooth/network information as suggested in some topics, but their problem it seems different from mine.

Any clue about this?
I checked in the repository and I didn’t find any issues, so I suppose it’s a problem only on my device.

After checking the issue, I tried to install “e OS s” to check if it’s a problem only on the R version but the problem remains.
I double checked on Stock android 11 and stock android 12 if it’s working and it is.

At the moment I’m on stock Android 12, but if you need some screen and anything else, I will install anything that could be useful.

Thank you in advance

EDIT: I checked all the GPS-related issues that I was able to found:
6586 6438 6578 5984 (Only 2 links due to new users limitations)

6438 is the closest to my problem. The workarounds mentioned in the various issues don’t work.

Hello @Fav0z Please check if Advanced Privacy does not fake your location. Some people had that issue also on other devices.

I have Pixel 4a and GPS works just fine.

1 Like

Yes it was deactivate.
I also tried to activate and deactivate again.
But the location from the network is ok, it’s missing the gnss position.

Which version are you using? Right now I’m on stock android so I can do a fresh install.

I have installed around december with the easy installer and currently I am on R 1.8.1 stable.

What app are you using?

I tried on both R and S, and to test it, I tried default openmaps, but also g maps.
After the problem I downloaded “GPS test” that shows the satellites and the position estimation.
On stock android it works just fine, and the latitude/longitude are correct.
On /e/ OS they are missing, the fields are empty.

Example below:

I installed the GPSTest app since I was wondering what it will show. I even turned off network location. After some time it found me even inside a building.

Never had with any other device your issue, so I can’t help you further. I assume you have all the possible settings set correctly…

1 Like

Can you check on your device the localization services?
It should be under: Settings → System → microG → Geolocation modules

I see only network based service and the addresses’ location service.
Is that ok?

Same, one is ‘Mozilla Locatuon Service’ and the other ‘Nominatim’. Should be standard.

1 Like

I also have a Pixel 4A with /e/OS. Geolocalisation doesn’t work most of the time inside buildings and may take a minute or so outside before it starts tracking me. I’ve always assumed that not relying on Google’s services makes it less accurate.

What has worked for me a few times is to disable localisation (Settings → Location) for a minute or so and re-enable it. Make sure to fully close the app that uses the GPS first.

1 Like

Ok, outside works, but it’s strange, it work flawless from inside with the official android.

Could be, maybe they use some filter not available in microG

Maybe the network location service just works better than the one from mozilla :smiley:

AFAIK The Mozilla’s one is for the network location, not GPS

This video may help answer some of your de-googled GPS questions


AFAIK: The network localization helps to identify your position quicker since gps by itself only shoots the signal vertically to the earth and beeing in a building makes it harder. :man_shrugging:

1 Like