Pixel 4a with easy installer. Experiences? Opinions?


i recently installed /e/ V1.2 with Easy Installer in a FP3, and although i thought i wouldn’t be able, i finally managed to do it and the experience was very satisfactory.

I saw in that the Pixel 4a is listed in the easy installer compatible devices.


Im thinking about buying a second hand pixel 4a and trying to install it via Easy Installer, but i didnt find many experiences about itand there is no documentation about the installation of drivers. If anyone has tried or achieved to install /e/ via Easy Installer, I would be glad to hear his or her experience.

Thanks in advance


About two weeks ago I bought a second hand Pixel 4a and installed /e/ on it. As far as I know, v1.0 is the latest version available? At least I haven’t received any OTA updates.

The installation was quite easy (even for someone with no prior Android experience).

Everything has worked well so far except Netflix won’t play any videos. I recently opened a thread about and the only workaround out there doesn’t seem any easy for me to do: Netflix 5.10 error - #4 by tcecyk

thanks @clementprd ! Glad to hear that the installation process went well. The only thing that turns me back a little is that the pixel 4a doesn’t have SD card slot, and I have all my data, music, photos, apps backups… (about 125 GB!) in the SD card, so even if I buy the 128 GB one I fear that the data transfer will be much complicated than just inserting a SD card… The thing I like about the pixel (in contrast with the FP3) is that it is more compact (apart from other better specs).

Did you buy the phone with Android 12 or Android 13? Because I think I read in some thread that with Android 13 the Easy Installer wouldn’t work properly…


I also chose the Pixel 4a because of its size. I think it’s one of the “smallest” Android phones that is not crazy old. I also wish Fairphone would have built a mini version…

Mine had Android 11 installed on it. /e/OS 1.0 is also on Android 11. I believe I read somewhere that your phone shouldn’t have a more recent update of Android before you install /e/ on it (please double check this!).

Nothing wrong with “crazy old” phones :slight_smile: They still work, they mostly have enough resources for most things users are likely to want to do.

Sony have made some great compact phones, many of which are offically supported by /e/. In reverse chronological order

Compare the specs on GSM Arena.

In addition, “semi-official” builds (with OTA updates) exist for XZ1 Compact 2017. I’m using this device as my 'daily driver`, running a custom build of Lineage for MicroG 18.1. This phone - like the Z5 Compact I used before - does everything I need, it can run Android 11 / LOS 19.1 , and I have no need for anything newer.

1 Like

The Sony phones are ok @petefoth, my problem is that I can only install /e/ via Easy Installer, as I don’t have the knowledge nor the time to start learning the process of manual installation. When I saw the Pixel 4a was in the list of the Easy Installer compatible devices, I was glad to see a compact, recent good phone which people without much technical knowledge could install /e/ on it.

By the way, @clementprd how did you transfer your data to the Pixel 4a if there is no SD card slot?

Same experience. I chose the Pixel 4a because it was supported by the easy installer.

I haven’t migrated my photo library from my iPhone yet. I’m looking at either creating a Murena account or (I would prefer) a Proton one. Regarding contacts, calendars, etc. I’m using a CalDAV/CardDav service so everything synced up automatically.


I running an installation on a Pixel 4 right now…Seems to be hung up on the Device Detection step. Been here for quite a while. Even tried changing machines and changing cables. Might have to look for some help.

Not sure if you directed that question to me, but I’ll update you on my process.

It was 100% successful. I was amazed at how easy it was. My hang-up was because I’d apparently missed an initial step. I think it was turning on de-bugging or something. I thought I’d done it, but I’d not. Went back through the process more carefully and it worked perfectly.

I’d recommend you take your time, eliminate all distractions, and follow the steps carefully.

Also, the resolution on my notebook did not allow the full setup screen to appear on the monitor so I had to hook the notebook up to a television screen to be able to see and access the “NEXT” or “CONTINUE” button as it would not scroll down to expose it. Other than that issue and my own carelessness, it was a no-brainer event.


It seems i m stuck in the process at “rebooting in developper mode”
It is like this since 25 min. I m pretty sure i have enable usb debugging and oem unlocking.
Here is a picture of the phone screen. The software on the computeur only show “rebooting on developper mode”
The bootloader is locked but i have read nowhere that i had to unlock it before the easy installer start.
What should i do ? I m afraid to unplug anything !

Thanks !

Hello @Katem

I think you can just say start by using the button and the device should boot into it’s OS.

There is no “rebooting in developer mode”. I have used the easy installer with FP3 and recently with 4a like you are doing.

What kind of a Version was installed when you started the installation of eos?


It s fine ! The easy installer on windows was stuck at " rebooting in bootloader mode", sorry my mistake ! (see picture)

But i try another time on linux and it went perfectly well ! Idk what happened (maybe windows just sucks I guess :wink:
To be able to use the easy installer I had previously did a downgrade of my pixel4a from android 12 to android 11 through the online android tool, it is pretty convenient btw !

The pixel 4a seems quite good ! I also have a FP3 with eos on it :wink: and i really enjoy it, but so far the pixel phone is small, fast, take great pictures (compared to FP3).

But i realize in the process that the end of support is near. Google ends support in august.

Calyx OS annonces suppport until february 2024 but no engagement beyond. Does anyone know if Eos update/upgrade process will extend those schedules ?

Thanks !


I would expect /e/OS to upgrade Android Security patch level for a considerable time. (Personal experience ~4 years on two devices)

Vendor Security patch level will stop as per Manufacturer notice.

Hi @Katem , you said you downgraded from android 12 to 11. Do you know if it’s possible to downgrade directly from 13 to 11? (I bought a second hand PIxel 4a and came with android 13)

Hi @graz With the tool from Google, it’s not really a downgrade, it’s a flashing of the version needed :blush:.

Never done it, but my guess is that with their online tool that I used, it is gonna be perfectly ok !
Let us know if you succeed !

Ah, ok! Thanks @Katem and @mihi :slight_smile: