Pixel 4a5G bramble - can't install recovery

I just got this phone and am trying to install /e/os. I followed the instructions and successfully unlocked the bootloader. I went to install recovery and nothing was happening with no error messages (same as below). I missed the part where I needed Android 11 stock - so I used the Google tool to flash that. It worked. When I installed I clicked the “lock bootloader” option to off.

So I launch into 11 stock, turn on dev tools and usb debugging. I can get to bootloader, but when I go to install recovery it just sits there and does nothing. Here’s my commands.

[bg@lemur pixel.4a.5g.bramble]$ fastboot devices
09301JECB29208  fastboot

[bg@lemur pixel.4a.5g.bramble]$ fastboot flashing unlock
(bootloader) Device already unlocked
OKAY [  0.054s]
Finished. Total time: 0.054s
[bg@lemur pixel.4a.5g.bramble]$ fastboot flash boot ./recovery-e-0.23-r-20220404175826-dev-bramble.img 


When it goes to flash the recovery it just sits there, blinking cursor - nothing happens until I ctrl-C.

I’m using Manjaro so I’m pretty sure I have the latest version of adb and fastboot.
I’ve installed custom ROM’s before, but I don’t remember having this problem. The phone still boots fine into Android 11. I’ve also tried different cables. I’ve used this cable and port to install on another phone too. I kind of feel like I’m missing something obvious. I’ve tried installing via sudo as well.

Check your fastboot version: fastboot --version
I think the latest is 33.0.1

1 Like

Weird - looks like the AUR is two full versions ahead. Currently I’m on 31.0.3. Kind of weird for Arch to be that far behind.

Try using sudo: sudo fastboot flash boot ./recovery-e-0.23-r-20220404175826-dev-bramble.img If I am correct, sudo works under Manjaro, otherwise try it as root.

I’ve had issues flashing my phone on certain Linux distros. I’ve found ,personally, installing Mint or Ubuntu on a spare computer and flashing my phone from that makes flashing much easier.

Thanks for the suggestions. I was wondering if the version of twrp matters that much? As far as the image that comes from the /e/ os repos? I know there are some differences that different distros install verses the regular version you can get from developers as well as things like LineagOS which makes quite a few changes from what I can see with the install instructions.

I did try installing via sudo, though not as root itself. As I said I’ve flashed another phone, so it probably has to do with the android-sdk version. I looked at the Arch repos that Manjaro uses and it is marked as “Out of date” so rather than fiddle with the AUR vs. distro repos I’ll probably just wait until there is an update.

1 Like

When I was having similar troubles, I was using Fedora not Arch, but switching an Ubuntu based distro made the installation process seamless for me. And as long as you have the most recent recovery and zip file, you should be fine. Also, I’m using a Pixel 3a, so both our installation instructions should be very similar.

While you got the message

(bootloader) Device already unlocked

after you had done

fastboot flashing unlock.

In the first instance I would still just go back to Restart and re-enable USB debugging – just because we know we need a restart after the unlock.

To put it another way, I would read “Device already unlocked” as in “Device is unlocked” as in “Device is unlocked now” !

The advice here Installing adb and fastboot on a Linux PC, which I follow, is not to use “system” platform tools, whichever distro you use.

You ask about TWRP version, there is information here, TWRP 3.6.0 Released.

Again, in the first instance I would go with /e/ recovery. (It is built with the OS, so we know it is the best possible match.) It is easy to change to TWRP later if you find you need it.