Problem when charging phone

Ciao. Today I put my phone on charge. I went back after an hour and I realized it did not charge. I thought I did not put the cable correctly but it was ok. I’ve also checked the cable but is fine (can charge another phone)

If I turn the phone off and I plug the charging cable the phone goes in a loop and keep booting. It shows the “fairphone” logo, it goes black screen, it vibrate and then it show the fairphone logo again. Forever. Funny thing is that while it does this … the battery charges.

Any ideas ?

I’m on the latest “e” operating system that I’ve installed 6 days ago.


Which Fairphone do you have, Fairphone 2, 3, 3+? Which charger? Which cable?

In general make sure the cable you use is USB-IF certified explicitly, that should give the least trouble.
Even if your cable charges a different phone, that doesn’t say the charging circuitry of the Fairphone would like it, too. Could happen the other way around, too, overall USB in practice is not like USB in theory :man_shrugging: .

1 Like

Have you ever successfully charged this Fairphone with this charger? At least the FP3 needs a powerful charger. I also could not use the charger I had from before, I had to search for a more powerful one which was able to provide the needed current.

How powerful is powerful?
I could charge my Fairphone 3 with a 0.8A charger, and reasonably fast, too.
I wonder if I ever tried a computer USB 2 port delivering 0.5A max., though. Hmmm …

I can’t be more precise but I have several chargers and not every one is now good enough. The charging process on the FP3 doesn’t start at all when I use a wrong one.

My previous phone was much more robust in this situation. Sometimes it said, it will take a lot of time using “not the original charger”, but it did always charge.

Especially I miss the capability to use my solar panel for charging. This was always good up in the mountains because here in Switzerland many mountain huts have no facility for charging anything. The FP3 is now my first phone which refuses the solar panel completely. (On the other hand the accu is great.)

Hello Irrlicht,
Perhaps an idea. I owned a Waka Waka Power+ solar panel and with the original cable I can charge my FP3.


I just charged my Fairphone 3 totally fine with 0.5A (I assume, as per USB specs) via a computer USB 2 port, so the current is unlikely to be the lone culprit.

We can agree on the charging circuitry of the Fairphone 3 being seemingly somewhat picky overall when negotiating the charging process with all tech parties involved, but I can only say the thing I linked to: For me clearly the cables are the more deciding factor, not so much the chargers.

I use always the same cable (because I have only one). But I have multiple chargers from phones, sports watches, a Bluetooth head phone and at least one I bought additionally.

Of course it depends of the power of the solar panel. I have a SIStech which should not be so bad. But it doesn’t work anymore. What I can do is charge a powerbank and when the time has come use the powerbank to charge the FP3. But that’s a long way round, takes a lot of time and leads to losses.

Ciao. I’ll do some more test later today. Curious fact is that I can charge my FP when I connect with the very same USB cable to my laptop (a Dell Precision).

Keeping you posted.

I have a similar problem with my FP3 (non +) since the last update: I plug it in to charge, the green light shows but stops after a few minutes.
After a few tries I eventually manage to get it to charge but I’ve had a few bad surprises some mornings.
I doesn’t seem to happen when plugged in the car, on a PC or laptop.
I’ve tried with different cables and charger (I use Fairphone cables)
I’ve also taken the phone apart and cleaned all the connectors and made sure no screws were loose.
My wife and my daughter both have a FP3 running on stock android and use the same cables and chargers with no issue, so I tend to think there might be a problem with the last update…

Can’t confirm so far on 0.16-q-20210424112062-dev-FP3.
(Settings - About phone - Android version - /e/ version … long-tap the version string to copy it to clipboard)

Which latest update are you on?
For the Fairphone 3 /e/ currently offer two different major Android versions on several different release channels, which all get updates.

I have this version

Aaaaah! Didn’t see there had been a new update 10 days later.
I’ll install the update and tell you if the issue is resolved

Just a little feedback.
Since I updated my FP3 with 0.16-q-20210424112062-dev-FP3, the charging issue has disappeared.
It was probably a software bug


Very recognizable.
My FP3 charges very slowly. How can I force fast charging?
I am using an original FP cable and an original Fp charger.
Initially my phone was on fast charge every time when charging.