Problems with multiple apps. Mail app crashing on launch, etc

I bought a Galaxy S9+ from /e/ and my main problem is I need to avoid doing a hard reset currently because my Signal app is linked to a number that does not work internationally, and I am travelling until Feb…

Is there anyway to make sure my phone is set up correctly if I added my /e/ account after first setting up the phone, without doing a hard reset?
In “Users & accounts” i signed into my /e/ account and it shows my email address for /e/ account, and for /e/ address book it writes: "Contacts ( 3A)

I really need google maps for navigating in Japan right now:

  • Google maps doesn’t work, it needs chrome, and chrome crashes on launch. Can google maps work without Play services?

Problems with Apps that I’ve encountered:

  • Mail app always crashes on launch (I switched to k9)
  • Uber says there is no internet connection.
  • Jump app won’t sign in.
  • Yelp doesnt show my location dot on the map.
  • Unlock pattern opens sometimes over camera app when i double tap the power button (happens when “Directly Show Pattern View” setting is enabled, in screen lock settings)
  • Open Camera flashes a green screen every second or two while recording video
  • JapanTaxi hangs on launch load screen.
  • TripLingo sometimes hangs on a white screen when openned, and doesn’t seem to run well.
  • twitter main app won’t install

Yes, Google Maps works on my /e/ phone even without the Google services…

/e/ OS is in “beta” development stage (e-0.7-o-) and does not yet contain 100% coverage of all requirements. Detected bugs will be fixed as soon as possible.

The /e/ Release Candidate 1.0 is expected in February 2020 at the Mobile World Congress Barcelona.

Nobody can expect that everything will work fine at this time.

OK good to know gmaps works. I’m just looking for things to try, short of doing a hard reset.

I’ve installed /e/ Os on my Motorola G4 plus with TWRP.

Version 0.7-2019101126749
Just after the default setup where I entered my /e/ account informations, the mail application Mail crashes continuously.

Though the integrated nexcloud client works great, it syncs. Same for carddav and caldav synchronizations.

Is anyone experiencing this with Mail? Is there a way to solve it?
I’ve tried without more success to give all permissions to Mail, delete its cache and data.
But I noticed that the additional permissions, although given, do not remain in the settings.

Hmm weird, I gave Mail all permissions too, there are only 2 permissions… they seem to stick, but its still crashing.

Re: Google Maps not launching- SOLVED

For anyone else who might have this: I had set Firefox as my default browser before installing g-maps. This seems to have caused it because I simply set the “Browser” app as default browser again, opened g-maps, it works now. Even with Firefox set as default again.

For information, it may be solved.

I’ve just come to delete the /e/ (fork of davx5) account which manages Caldav & Carddav, created during the vanilla setup and then the Mail (fork of k9mail) launches.

I’m going to investigate a bit more.

Edit: so I had to delete the /e/ account to be able to launch Mail.
But when I recreated again the /e/ account I got again a crash of Mail.
The trick was to create only the /e/ Address book account.

Good to know. I’m just wondering how it is better than k9? I know its based on k9, so that’s good.

@Manoj, thanks for the edits in the original post. I would add my solution to Gmaps too but it doesn’t give me the option to edit anymore.