PSA: do not disable the default keyboard

I recently disabled the default keyboard, and after a reboot, I couldn’t type my password anymore. It seems that /e/ doesn’t recognize OpenBoard before unlocking the device. My only hope (apart from a factory reset) is to purchase a USB-C to USB connector and hope that my old keyboard works.

Moral of the story: don’t disable the default keyboard.

And to the devs: perhaps don’t let curious yet slightly dim tinkerers like me disable it in the first place, or at least add a warning message?

3 Likes

A few months ago I made the same mistake on stock Android. Before this happened I had thankfully enabled USB debugging on the device, and had set it to trust my computer, so I was able to use adb from a terminal to simulate keypresses on the phone.

I can understand why one would want to disable stock Gboard on Android, to prevent it from possibly sending any data to Google. On e-OS this should not be necessary, as the default AOSP keyboard should not (though I haven’t verified this myself) be sending data to Google.

I reproduced this on e-OS today and found that, like in stock Android, it does warn you that Openboard cannot start before the system is launched (see screenshot). But I do think this message is somewhat easy to misinterpret (I did misunderstand it myself!)!

2 Likes

Maybe a simple explanation : the keyboard app is running as user, so it is not available at boot time.

I’ll try to install it as system app (lots of posts about that, here).

2 Likes

Just so that it is mentioned:
If you use a PIN instead of a password, the keyboard won’t be necessary for the input, the PIN prompt uses its own UI.

4 Likes

On e-OS this should not be necessary, as the default AOSP keyboard should not (though I haven’t verified this myself) be sending data to Google.

True, I’m not sure why I wanted to disable it in the first place. An overzealous drive to tidy up, I guess. Or a remnant from my Android days where stock apps were actively harmful.

it does warn you that Openboard cannot start before the system is launched (see screenshot).

Funny, I don’t remember seeing this message at all, but I tried it myself and there it was! So my ‘advice’ to add a warning message was completely misplaced, and I just haven’t been paying attention. Thanks for the reply!

1 Like