Running Easy Installer

Hey, I’m running into a problem when trying to start Easy Installer.
I installed it using snap. When I start the program I get the following error:

    Exception in thread "main" java.lang.reflect.InvocationTargetException
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.base/java.lang.reflect.Method.invoke(Unknown Source)
	at java.base/sun.launcher.LauncherHelper$FXHelper.main(Unknown Source)
Caused by: java.lang.UnsupportedOperationException: Unable to open DISPLAY
	at javafx.graphics/com.sun.glass.ui.gtk.GtkApplication.lambda$new$6(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at javafx.graphics/com.sun.glass.ui.gtk.GtkApplication.<init>(Unknown Source)
	at javafx.graphics/com.sun.glass.ui.gtk.GtkPlatformFactory.createApplication(Unknown Source)
	at javafx.graphics/com.sun.glass.ui.Application.run(Unknown Source)
	at javafx.graphics/com.sun.javafx.tk.quantum.QuantumToolkit.startup(Unknown Source)
	at javafx.graphics/com.sun.javafx.application.PlatformImpl.startup(Unknown Source)
	at javafx.graphics/com.sun.javafx.application.PlatformImpl.startup(Unknown Source)
	at javafx.graphics/com.sun.javafx.application.LauncherImpl.startToolkit(Unknown Source)
	at javafx.graphics/com.sun.javafx.application.LauncherImpl.launchApplicationWithArgs(Unknown Source)
	at javafx.graphics/com.sun.javafx.application.LauncherImpl.launchApplication(Unknown Source)
	... 5 more

I’m running a manjaro-machine. Can someone help me please?

Unable to open DISPLAY

Under normal circumstances I’d interpret this error that you tried to run the command over ssh or with su but I don’t think that’s the case, right?

I have to admit I’ve never used Manjaro Linux, nor do I have experience with snap packages.
How did you start the installer?

I tried to run it over su but that didn’t help. I first started it via the standard gnome menu. And then with the terminal to see what’s wrong. Is there another way, other than snap?

Ha! It’s wayland. I tried running it in a xorg session and it worked. Thanks!

1 Like