S9 ERRROR: 7 while installing OS

Hello everyone,

While loading /e/ on my S9 I’m always getting the Error 7. I already tried to change the TWRP Version but it’s still not working.

What could I do?

Thanks a lot for your help already in advance!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

To solve "error 7” from twrp 3.4.0-0, you have to change /data format system to Ext3, and then re-change to Ext4

Have you formated the /data partition since you use TWRP 3.3.1-1 or 3.3.1-0 ?

Thanks, yes I did. You mean in the wipe - data - repair or change file system - change file system, right?

I did the wipe option yes. I tried to downgrade to TWRP 3.3.1-1 but I still couldn’t install /e/

Try an older version like 3.3.1-0 it is the reference version for pie
Or try the easy-installer…

@piero The easy-installer is kind of working but it wont boot after. I’m just getting the “Samsung S9” boot screen and it keeps trying to reboot but it doesn’t get into the OS boot.

It works now. I had to downgrade the TWRP to version 3.2.3-0 and then I was able to install with the easy-installer.

1 Like

Happy to hear that you managed to make it work,
someone may understand why