S9 Stuck at the e's bouncy dot after update

Hi all.

I hadn’t been receiving OTAs for a looong time so yesterday I briefly checked that there are new updates at /e/ image ROM download, grabbed the newest one and installed it through TWRP.

The phone restarted but got stuck at the bouncy dot – only after rebooting to the e’s bootloader I noticed that TWRP was replaced…

What can I try to get my phone back to a working state before nuking it with a factory reset (which will or will not fix it, anyway, that is yet to be seen)? I was thinking re-flashing TWRP and the last ROM version I had (from Dec '21), but the image archive only goes back to 1.0.

TIA for any advice.

PS Nope, don’t ask about backups.

Reflash TWRP, make a backup of your data. Then format data, flash the new ROM, reboot and go through first time setup, setting whatever screen protection (pin, pattern) you had before. Then, in TWRP, restore the backup


Cheers! For now I kinda went about it my way: reflashed TWRP, vendor and the last used build that I found in my archives. It looks like I missed the release of 1.0 and all the fun that went with it. Is there any ‘official’ way to transition to 1.0 or do I follow what’s in your post? (That would be a little weird tbh because I still have to revert to TWRP and not used the new /e/ bootloader, no?) Thanks again.

1 Like

Yes you want TWRP.

The transition to v1.0 is not that problematic. Were you previously still on Oreo?

If yes, the more difficult thing is that with this change of version you have to Android version Upgrade from 8 to 10.


Yep, still Oreo. Should I expect trouble? I read people had loads of issues with 1.0, did they get rectified in 1.3? This phone is my daily driver so I’m a bit between the devil and the deep blue sea: either continue to use an outdated ROM or risk unstable behaviour.

Yes a big improvement.

So you never received the OTA Upgrade which should have done both Android and /e/ version change together without the need to depend on your own backup.

If Oreo is still working fine you can organise your backup plan, the go ahead just as @petefoth indicated in your own time.

I do not find an Upgrade page for this device, for reference there is


Nope, the last one I received is 0.20 from Dec '21 that I reverted to now after that unsuccessful update two days ago. In the hindsight, probably a good thing!


I got around to sorting it out finally, so a quick question: assuming I will successfully update to 1.4, will I be able to receive OTA updates later on, even after I revert to TWRP?

After installation of e-1.4…

TWRP can’t manage OTA update because its lacking in managing encrypted /data partition

Solutions are :

use the recovery-e instead of TWRP for OTA updates


use install feature of TWRP instead of OTA updates

1 Like

I thought it would be like that, thanks for confirming.

Does it mean I’ll have to reflash the recovery to have TWRP every time, too? That last update to 1.3 replaced my TWRP with recovery-e without asking.

I think it is during first boot setup wisard

You should unselect it in -->settings -->updates -->3dots → paramettres -->update recovery

1 Like

Thanks, I don’t have this option in Oreo, I’ll check once I’m on 10.

Just to make sure, from TWRP I only restore Data (ie leave System, System Image, Boot and Vendor Image unchecked), correct?

To answer myself, correct.

A weird thing is happening, though: after the restore, not all my apps are showing. They’re there because when I ‘install’ them from F-Droid or Aurora, I’m getting an update rather than install confirmation pop-up. Also, it looks random – I ran through the whole process twice, and different apps were missing each time. Any idea how to make them reappear without having to meticulously update one by one, anyone?

As a first step can you try to clarify the problem apps? Perhaps go to

Settings > Apps and notifications > See all … apps > App info can be opened for selected App

It is a big ask of the TWRP data backup alone to transfer a backup all the way from Oreo to Q.

Perhaps identify an app that shows as “update rather than install confirmation”; go to the app info page for that app. > Advanced > STORE.

This may not usually be too much of a blocker, but
a) Try to update from the original STORE source
b) if you find the App came from a store you do not plan to use now the app could be uninstalled from the app info page.
c) some apps may have come from Apps. Does a problem arise in this case? I guess this would indicate the current App Lounge is using a significantly different source.

Perhaps after a reboot, try now to install the app for a “fresh start”.

If STORE is not the issue (that is that you can update from the same source as originally) then I guess that app’s data got corrupted somehow by the TWRP backup.

There will also be a number of “Oreo” apps which are using a significantly different workflow in Q.

I see this as a divide and rule approach to minimise the apps you will have “meticulously update” but I think it will be “one by one”.

If you list problem apps here, others may recognise the issue.

1 Like

What exactly did you do?
I have the same problem, just stuck at the e recovery without any backup. Is it possible to replace TWRP and than just go back to e0.20 and everything is good?

Using recovery-e, you must be abble to flash any (custom OS) version you get.

Not sure which step you’re asking about.

To bring my phone back to a usable state I did this:

But reading your thread I think you’re past this step because you formatted Data, which means your auto-archived builds got wiped.

To properly update to 1.4 I followed petefoth’s advice:

Actually, OTAs are still supported with TWRP, but the trouble is they include RECOVERY so I need to flash TWRP after every update install.

I don’t have that option – here’s what I get when I go to Settings > System updates > 3 dots > Preferences:

@reb77 @piero
Thank you guys so much, I was realy lost because I am just a beginner in this. Realy I am so happy that you helped me!!
Have just the problem that the Sim has no service ( it’s locked). Tried it with a stock os for my phone (S9 SM-G960F,germany) but still nothing. Maybe it’s not the problem of the phone?

How did you determine this ? Which carrier supplied the SIM card ? Is the device itself Carrier locked … perhaps ? or do you simply need to ask the carrier to supply APN, in which case check out some apn threads, perhaps ?