Samsung - Galaxy A5 (2017) - a5y17lte - Documentation Suggestions

Please add your suggestions to improve the documentation for the Samsung - Galaxy A5 (2017) - a5y17lte here …

I have some suggestions to improve the documentation even further:

  1. I upgraded from /e/ OS Pie to Q without Wiping the storage despite I had my storage encrypted. It worked without any problem, all data is where it was before (I used TWRP 3.5.0). It would be annoying if I had stuck on the documentation, because then all my data would be gone. Why it is saying you have to Wipe everything before upgrading?
  2. The Link to the Stock ROM isn’t working, it says “Page not found”. For me it worked always without flashing the ROM first (also without any disadvantages)
1 Like

The instructions about enetering recovery mode from download mode need to be improved by importing the bits missing that are now in the lineage wiki:

  • A blue transfer bar will appear on the device showing the recovery image being flashed.


Note: The device will continue to display Downloading... Do not turn off target!! even after the process is complete. When the status message in the top left of the device’s display reports that the process is complete, you may proceed.

  • Unplug the USB cable from your device.
  • Manually reboot into recovery, this may require pulling the device’s battery out and putting it back in, or if you have a non-removable battery, press the Volume Down + Power buttons for 8~10 seconds until the screen turns black & release the buttons immediately when it does, then boot to recovery:
  • With the device powered off, hold Volume Up + Home + Power.


Note: Be sure to reboot into recovery immediately after installing the custom recovery. If you don’t the stock ROM will overwrite the custom recovery with the stock recovery, and you’ll need to flash it again.

1 Like

After being followed the tuto, I had a problem with the sim card compatibility (not recognized at all): I think there were an incompatibility with the firmware delivered with the phone. I flashed a newer stock ROM from 2020/12/16 and re-followed the tuto and now all works good.

I advice you to check your firmware version before starting the [tuto]. Normally you can see info in the “/system/build.prop” file, I don’t know more about the versions with the bug on not.

sorry for my english :smile:

after one +1 month of testing on my Galaxy A5 (2015) SM-A510F, the testing result was satisfactory.
I have decided to move forward.
Just installed /e/OS v1.7 (R) on my Galaxy A5 (2017) SM-A520F.
works good so far.
I will use /e/OS as my daily driver.

Thank you so much.

1 Like