SAMSUNG Galaxy A7 (2018) - help with first time GSI

I would like to start off with, hello, this is my first post.

lets get into why i have shortly registered on here, (i like to preface this by saying i did not find a similar topic with my specific device, galaxy a7), i tried to install eOS on my samsung galaxy a/ with this guide: Install /e/ on a Samsung Galaxy A7 (2017) - “a7y17lte”

things worked perfectly well up until a certain point, up until " Installing a custom recovery" “nr5”, i had no problem until this, it seems i had a blue progress bar (i saw a tiny slither not filled?) and waited several minutes before unplugging and rebooting into recovery mode, i was unable to do so and i tried to soft reset.

which leads me into my problem, i am now stuck in a bot loop i cant get out of, neither with power and volume down, nor with letting battery run out, just pressing the power button wont do anything.

thanks and any help would be appreciated.

Hi @AmandaOneill welcome to the /e/ forum. It is likely the first problem was due to “timing” of the reboot into TWRP for the first time: Know your hardware - Samsung.

For the bootloop, please can you try to “catch the moment” in the bootloop and use accurately timed button presses of Volume Down + Home + Power to try boot into Download mode. When lucky, you can just try to flash TWRP again.

Bon chance. :slight_smile:

thank you, my A7 only has the volume buttons and the power one (tho the combination normally works)
i do not seem to get this moment down, as previously explained volume down combo does the soft reset, i tried the method linked in the post but i am unable to either get it down, or function properly.

(I was going to say that on Samsungs with no Bixby/Home I have read that the connection of the USB cable can act like a trigger to simulate the “third button”.)
However before trying that, perhaps we had better check we are talking about the same device! Please can you check this link, Download Mode SAMSUNG A720F Galaxy A7 (2017), how to - - perhaps they are different models (there is a 2018 model listed with no Bixby/Home)?

my A7 has all button in the top right corner.
if im not mistaken my model is indeed the 2018 version it seems to have the exact same layout (cinluding buttons)

Hmmm, the next thing I would try is [HOWTO] Find device codename for your device. :slight_smile:

the back of my phone has the codename tiny printed on its back: a750fn
the full phone name should be: Samsung Galaxy A7 2018 SM-A750FN

Here is a xda search for that device Samsung Galaxy A7 (2018) ROMs, Kernels, Recoveries | XDA Forums. After your own searches (! :slight_smile: ) you might think about a change of plan to a Generic System Images (GSI).

thank you, with this other forum i am able to boot into download mode (im certain i tried every possible button combo in the end)
however, i now have the same problem as before, i cant reboot into anything else, only download mode is possible, i tried to flash /e/ again (without sucess since i cant use any button combo other than the one to get into download mode).
which should eliminate GSI as well?

Negative! :slight_smile:

My interpretation would be that it is great you have a working Download mode, ready for the next thing!

You can get no further right now because you do not have a TWRP and /e/ ROM which are an exact match with your device code!

I am optimistic.

i did try to see what the GSI guide says, frankly im lost at step one, since i apprently dont have the correct twrp version (i did install it via the aurora store as well before doing anything)
and i do not know how to do “extracting the kernel and reflashing it with the below command”
is there any other OS you recommend i might be able to install without having to go root? (which i cant right now anyway due to the problem of only being able to go download mode)

Please don’t be discouraged! The GSI instructions sound more heavy duty than they turn out to be - perhaps it is not a first timer’s ideal activity, perhaps it is felt that the /e/ ROM should be easy, but the GSI needs a bit of testing, so it is missing the easy to follow instructions. (Just my view!)

The TRWR app is not really recommended here, so that is no big loss!

From the XDA link, I think we will be able to find a recovery, this is the first that caught my eye [RECOVERY] [UNOFFICIAL] PBRP 3.1.0 For Galaxy A7 2018 | XDA Forums. I would do something completely different right now, then spend an hour researching that.

I am not in favour of doing this sort of job using a rooting technique - never have - I would aim to not read those methods.

There will be other ROM’s you could try, but right now you probably need the job broken down step by step.

The first prerequisite is the recovery - we are on it!

I have another suggestion that you edit your post title, perhaps to “SAMSUNG Galaxy A7 (2018) - help with first time GSI” (If this edit is not permitted for a new user and you would like me to do it, please say.)

wow, thats a lot, lets start with i did try to fiddle with heimdall to flash a twrp version that works, well, it does, kind of, i was able to boot into that version (but the screen seems to go black every now and than in random times on its splash screen?)
so i at least know i do indeed can go into recovery if i have the right version.

maybe it does so because of not enough power?

Power is a very good point, all these reboots are draining. Does your TWRP indicate battery level? You often see a + indicating charging. I believe it is a frequent cause of errors to flash with under 60% charge, so, yes, I would attend to that.

A recovery will often tell you the device code, or see if you can now collect that using my earlier link. (The device code will have a format similar to a7yxxlte)

One more thing, when you now click on the #gsi tab on your OP, you will see many relevant topics.

regarding power, its impossible to turn the phone off to let it charge faster, it will always reboot no matter what, its been charging for a while now, but it seems it does drain battery faster than it charges? since its still been flashing and occasionally back at the devices name splashcreen.

regarding the code, im fairly certain it is the same as previously mentioned “a750fn”? i do not see any other code for the short time the custom recovery shows.

so i think im basically stuck in a battery draining loop that causes the phone to turn off, turn back on, drain battery and repeat., to say it again, as of right now i think its impossible to have the phone turn off and charge faster as it reboots every single time.

edit: when i plug the phone into a normal power charger this loop either breaks, or as i suspect there is even less power to charge the hpone, thus no power to even reboot.
last option would be that its not na power problem at all?

Please can you give the source of your TWRP? The correct recovery would be expected to be stable even under these circumstances. Sorry to bang on about it but the model number a750fn is not really sufficient in searching for a recovery which must be exactly correct.

If the battery should fully drain and the phone goes off it is usually ok (or even a benefit), because the charger will then behave correctly and fully charge the battery.

i used the one used in this guide since it had the same model name as mine

the question would be now, how would i be able to find the correct codename and thus, recovery now that it seems to be stuck in the same problem, only now i cant seem to get into download mode anymore.

PROGRESS, twrp booted and doesnt just vanish, i wont do anything and wait for your expert opinion
battery is apparently at 23%

Edit, crossed posts! Great that you get a break. (Your link above mentions that will need root and includes the wording “If you’re a power user”.

I would go down my earlier mentioned Pitch Black Recovery Project 3.1.0 route: [RECOVERY] [UNOFFICIAL] PBRP 3.1.0 For Galaxy A7 2018 | XDA Forums

You will see that the method “from PC” allows you to “temporarily use” the recovery - you will notice you do not flash it in one go.

upon closer inspection, it would required me to download this mentioned zip onto my device, which frankly, i have no idea how to do when i cant boot?

would it be better to try factory resting from twrp and start fresh? if so i would seriously appreciate help afterwards (if it works that is)