Samsung Galaxy S7 unresponsive and unable to boot into EDL

I installed Samsung USB drivers and the easy installer. Once I got to the step where I needed to boot into the custom recovery that was flashed my phone didn’t response when trying to power on. I’ve tried force shutting down the device to try and boot it back into EDL so I can at least put official Samsung software back on the device however it isn’t even booting into EDL.

I followed the instructions exactly as they were laid out in the easy installer and I’m quite worried that I now have a paper weight after using it.

Hi @Savings5239 welcome to the /e/ forum.

It is very hard to brick a Samsung. I don’t mean to sound pedantic but EDL is a Qualcomm thing not used by Samsung. Are you referring to Odin mode?

Does this fit with this:

It sounds as if you might have failed at “Your first boot into TWRP” (I can’t tell) but you might read that section of “Know your hardware” too, if you were to try again.

I tried booting into EDL mode however I was unable to, the day of installation the device booted with the /e/OS boot logo however the screen promptly went black, the device became very warm to the touch and ever since I’ve been completely unable to boot it whatsoever, it doesn’t even seem to charge. I followed the automatic installers instructions to a T.

Easy Installer only supports “Exynos” devices. Info about Samsung Galaxy S7 - herolte.

As you are using the term EDL, I think maybe you have a USA Qualcomm variant.

I have the Exynos version, Samsung has EDL on both versions.