Samsung Galaxy S8: ERR_NAME_NOT_RESOLVED on some pages


I have just flashed the /e/ OS which was no problem.

But when I’m using data over LTE I’m getting the error ERR_NAME_NOT_RESOLVED.
This happens only on some websites.
E.g.: works but does not work.
First I thought it might be a DNS problem and changed the DNS server (from telekom to cloudflare But this made things worse (no website was working after that) and I changed it back.

Then I thought it might be a problem of the browser. But when I wanted to download firefox with the app-store app this throwed an error that something has gone wrong…

After that I installed firefox via WLAN. But still the same problem with the same websites…
So it seems not be a problem of the browser.

Everything works with WLAN but not with LTE connection. My data volume on LTE is high enough!

Do you have any ideas?

Thanks in advance!


Did you try to toggle “Private DNS” setting ?

Thanks for your reply!
I tried it now, but it makes no difference when I switch it from “automatic” to “off”. When I set a privat DNS (cloudflare) it says that private DNS is not possible.

I tried it with the same SIM card on my old phone (Android 2.3.6) and everything works fine. Therefore I don’t htink it is a DNS problem.

But the old browser throwed a problem with certificates on the sites which don’t work under /e/. Might this be the problem that sites with certificate problems are somehow “blocked” by /e/? Is it possible to do settings in this direction (I haven’t found some so far)?

I have the same problem on the S8 - did you already find a solution?
Kind regards,

Hi Bernhard,

yes, I found a solution today. :smiley:

I wondered why no one else posted this problem and even the e foundation sells S8 phones and these phones also don’t seem to have a problem. Therefore I assumed that it might have to do something with the provider.
Therefore I bought a prepaid card of another provider and with that provider everything works fine and I’m very happy with /e/ OS now.

Kind regards,

1 Like