Samsung S6 lite - can't boot to recovery

I just can’t boot to e recovery, (power+vol up), always ending up at system boot. I’m pretty sure I used to, (I have a couple of Samsung devices so I might be confused), but I did also just update to 1.19 s

Any clues?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

There is expected an alternative way to boot into Recovery, Advanced restart. If you have Settings > System > Developer options enabled. (If not available, go to Settings > About phone > Build number, and tap multiple times on Build number) you can toggle on Advanced restart which will allow extra options in the Power menu, to Restart into recovery. Might be worth testing this first.


I see, https://images.ecloud.global/dev/gta4xlwifi/, that that the last Android 12 (S) build listed is in fact e-1.19.1-s-20240111372761-dev-gta4xlwifi.zip. If you actually have e-1.19-s-xxx... this might indicate the build was withdrawn and replaced, idk.

Your device will need a manual Upgrade to Android 13 (T) shortly, but I see that there is an issue reported https://gitlab.e.foundation/e/backlog/-/issues/7988.

One idea … does your System Updater, in the top right 3 dot menu offer Local Update? If yes you could try to download e-1.19.1-s-20240111372761-dev-gta4xlwifi.zip to a position on the device to which you can navigate. Now ensure that “Update Recovery” is selected within Preferences of the same menu. Maybe this would fix e-Recovery.

You were absolutely right about the developer option power menu. I can now boot to recovery again so thanks for that.

And yes, my plan was to upgrade to T via e. recovery, something I have done and worked well with my S9 from Q to S until I tried to go from S Official to T Community. So I’m only half expecting it to work, TBH, but my experience when it didn’t on my S9 was an easy e.recovery fix back to S.

Downloaded T to SD card and updated from e.recovery. Smooth as silk and no problems at all.

2 Likes