Samsung S9 encrypted after OTA update


After OTA update to Q, phone has been encrypted and twrp has lost its functionality. Factory reset doesn’t work and twrp is unable to make backups. Is there a way to decrypt phone?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Only solution was to hard install os again. It wasn’t fun, but now phone works like a charm.

But the main problem is still there. Twrp is asking the password, which I dont know. In twrp I can not make backup, it says something ‘unable to mount’.

When reinstalling the os, after installation is completed, it reboots and then comes the android logo and it says it is encrypting the phone. Why is this happening? Twrp is no longer valuable for me, because I cant make backups. I don’t believe I am the only one with this ‘feature’.

When you search for encryption on this forum, there are many unresolved threads. However, some form of encryption seems to me to be a “feature” and it includes “encryption with a default password.” (May be a Samsung thing?)

So if you are certain you set no password, then, when asked for it by TWRP, you must press cancel for “default”.

Maybe you have a bigger problem than this?

Pressing cancel lets me in to twrp, but won’t let me do backup. It says that unable to mount something something.

Phone works, but I am afraid when next updates come, it wont work because twrp can’t do anything.

Is this (April 2020) post reassuring? Can you encrypt your user data partition? … and this one seems well informed Advantages/disadvantages of encrypting phone.

I am now presuming that when you search Settings > Encryption, you see “Encrypted”.

Yeah phone is enceypted, but not by me. It was done by the /e/os update O to Q.

1 Like

Hi @HekatheGreat, your post in another thread, No answer to three of my e-mails/Unhappy with Samsung s9+ - #12 by HekatheGreat reminded me that I had not followed up here. You have been correct to say that when a phone is encrypted TWRP cannot deal with it.

As an aside, when a device is encrypted as shown in Settings > Encryption and you enter TWRP, you have very limited powers. As far as I understand it, if you take a step where you are asked for the password, when the phone is encrypted and you know that you set no password, you press Cancel in order to pass the default_password. Now you see the limited powers of TWRP in an encrypted phone. Please contradict me if I am wrong.

I wonder if you asked for advice to undo encryption?

I found this link which covers ways that you might try undo encryption. – I realise that the reason you might want TWRP right now is to make a data backup, before wiping the device, but (I guess) this will not be possible.

The method #3 is what I would try, using “”. This can be found from the device install page Install /e/ on a Samsung Galaxy S9 - “starlte” and copied here.

Patch the device

  1. Download the patch from here

The page is unhelpful in not telling us what the patch does !

An altenative method of patching the device from a PC is given there.

Of course, you still need to be advised to “backup your data first” !

However if you have learned to love an encrypted phone, I would fully expect regular OTA updates to be ok.

No worries for the delayed answer, the phone is working like a charm besides the unwanted encryption. BUT, the android encryption does not bother me anymore. At least my phone is pretty secure now, I think…

Now before the 0.23 update, I tapped on the developer option that “install and replace recovery along system updates” or something like that, and I now have /e/recovery, which is really nice thing. No twrp at all.

This phone is on my daily use, so I want it to be most reliable, and now with /e/recovery, I have better feeling about reliability. Proof me wrong…

I have no intrest of doing anything experimental tinkering on my phone with guides found on different forums on the internet. At least not with my daily drive…

I see you’re happy without TWRP now, but in case other users are reading along …

Google made encryption mandatory by default in Android 10 (Q), says the internet, so that seems to work as designed.

Encryption support in TWRP is not guaranteed for every device … Why doesn't TWRP support encryption on my device?

The only thing to try in this situation would be to set an unlock method for the lock screen, which will then serve as your decryption method.
For TWRP a password or PIN would be preferrable, because it is also not guaranteed that TWRP can prompt for a pattern (a translation from an existing pattern into a password to enter in TWRP is given at the end of TWRP Commandline Guide, if needed) … and this decryption password/PIN can be entered in the TWRP password prompt to see whether TWRP can decrypt the data partition with this.

If TWRP can’t decrypt the data partition with the correct password/PIN, tough luck. But hitting “Cancel” at the password prompt in TWRP will at least still let you through to all the remaining TWRP functionality without being able to work with the data partition.

Interesting suggestion, as with IT ‘you never know’ :-). I tried it, but that does not work. Setting a PIN code to the screen has no effect on the encryption password.

So until now my conclusion is: TWRP can no longer be used to backup/restore, as after installing /e/ v1 the /data partition will automatically be encrypted at first boot, making it inaccessible for TWRP from then on.
Well, that is maybe to harsh. Backup/restore of partitions still might be possible to microSD. But I still need to test that.

Update: no, I tried and I can confirm: on Samsung 9, with encrypted partitions, TWRP can not be used to backup partitions.