Samsung S9+ Q OTA upgrade : Only official released binaries are allowed to be flashed


I have a refurbished Samsung S9+ from the /e/ store.

I just received the notification to update to do the OTA update to Q. And, since I’m willing to help with possible bugs and do testing, I immediately tried to do the update. And well, I did hit a bug x) !

I downloaded and installed the update, it launched TWRP, and it applied the update, only to reboot and find myself with a « Only official released binaries are allowed to be flashed ».

Though, I need to note that I’ve never flashed phones. Though, I’m willing to learn (and I wanted to learn for quite some time, I just didn’t know where to find resources for that).

1 Like

Hi @LyesSaadi welcome to the /e/ forum.

This seems quite a heavy duty failure of OTA Upgrade. I really think you should ask for help from

I say this on the basis that this is a “Samsung S9+ from the /e/ store” which was previously on Oreo stable and OTA Upgrade attempted to Upgrade to Android Q. All these things should be mentioned in your email if correct. :slight_smile:

1 Like

Thank you for the e-mail :slight_smile: !

Solved :tada: !

It seems that my phone somehow bricked itself ? Anyway, thanks to the /e/ desk help, and a night tirelessly exploring the Android ecosystem (and setting up a Windows 10 VM to flash stock Samsung ROM :sweat_smile: !), I was able to solve this !

For anyone hitting on the same issue, you need to:
1- Revert to the Stock Samsung Android ROM
2- Reinstall /e/OS from there