Samsung S9 wont boot into /e/OS recovery


I have tried to install /e/OS on a Samsung S9 using the easy installer and when that failed I tried the command line installer on Linux Mint. What I found out is that the recovery file is uploaded successfully (it seems, because there are no errors displayed), but it does not reboot into the uploaded recovery screens as displayed in the easy installer.

In the easy installer on the page “Restart device in recovery mode”, the first step says to stut down using Power + Bixby + Vol down, but that does a restart and not a power down. At the same step using the command line method this message is displayed:
Note: Be sure to reboot into recovery immediately after having installed the custom recovery. Otherwise the custom recovery will be overwritten and the device will reboot (appearing as though your custom recovery failed to install).
This indicates that the the downloaded recovery file is custom recovery is lost. Therefore the original recovery screen is displayed (black background, yellow and blue text).

I found this post: Samsung s9, stuck in Downloading mode, saying to press Power + Bixby + Vol Up immediately as soon as the screen goes dark after pressing Power + Vol down, but that is not resulting in the custom recovery screen.

Any suggestions would be great!

Welcome to the /e/ forum @jaapstra.

Firstly “/e/ Recovery” and “TWRP” are Custom Recoveries, so the terms are sorta interchangeable in this context.

You have read some descriptions of this awkward step. Here is another Your first boot into TWRP.

Thanks @aibd, the link you provided clarifies some missing information from the installation guides. I have executed the steps exactly like you describe in the section Know your hardware - Samsung twice, both options you describe with the buttons with the timing explained in the video you link there. But it does not boot into TWRP. I have tried too many times and it drives me crazy. Whatever I do, nothing seems to help and I only get the original bootloader and nothing else.

My device is an SM-G960F/DS with Android 10, kernel version 4.9.118-… and security patch of March 2022. I’m stuck with this, any help would be much appreciated!

I can only guess … many Samsung owners have had a frustrating time at this stage (#metoo !). If you are getting the timing / switching right … then I expect that the flashing of recovery went wrong.

Is your phone on regular Samsung stock ROM – another Custom ROM might interfere, all /e/ instructions should be from a starting point of manufacturer’s stock ROM meeting this advice

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

Did you try a different /e/ Recovery ? You could try if you thought the /e/ Recovery was at fault. With TWRP one would usually try the latest version first, but you might try the latest TWRP 3.6 in this case.

Have you had the phone in use with wifi + SIM card previously … have you studied the Download mode screen with a magnifying glass for clues (post an image here, if you like) … are you facing one of the issues in the #Bootloader locked section of the Know your hardware - Samsung page ?

Thanks @aibd, I left the phone for a while because it frustrated me too much.

A few days ago I managed to get the recovery correctly installed and you were right that it seems that the flashing of the recovery went wrong when using the Easy Installer on Windows (Try the Easy Installer beta), which is not showing so many details of of the process. At least it did not show any information that either downloading the recovery file or the flashing of it did not complete successfully. Because this was the first time I did something like this, I did not know what I which screens would be correct to see or not.

Fortunately I also have a partition on my laptop to start Linux Mint, using that I followed the instructions on Install /e/OS on a Samsung Galaxy S9 - “starlte”, which showed much more of the process and if things went well or not. One of the things that I had to do extra is grant the USB connection extra rights so it could also write to the USB port (I guess that is disabled by default) every time I connected the cable.

This time the button combination got me into recovery immediately and the rest was a peace of cake. Thanks for your help, I almost gave up! But I didn’t thanks to you.

1 Like