[SOLVED] No message sound notification in loudspeaker, but can be heard loud & clear in earphones?!

Using eSolutions-sourced FP3,
“linear_FP3-userdebug 9 PQ3A. 190801.002 eng.root.20200701.154024 dev-keys”

When a message comes in, no message sound notification from the phone.
Behavior Settings to “Make sound and pop on screen”. Pop on screen does work, but no sound.
This used to work and I did not change the settings.
When the phone screen is off, the only indication I have that a message came in is the blue LED blinking. Not terribly useful when the phone is in my pocket. Oh and yes, notifications are set to on, both global and message app ones.
Similar behavior when going to the message notification settings and browsing the notification sounds: Normal behavior is, I should hear the sound of each notification I try-select: But I don’t hear a thing, except if I plug and put the wired earphones on. Volume settings are all set to the max.
The earphones are the regular Fairphone-supplied ones (that I bought from the eSolutions shop site).

Thanks for any clue!

Follow up:
Not sure this is related, but shortly after this problem showed up, I noticed a phone problem, too, on
incoming phone calls:
I couldn’t hear people at the other end talking and they couldn’t hear me.
When I plugged the wired earphones, I could hear them and they could hear me.
If I then unplugged the earphones, I couldn’t hear them again and they couldn’t hear me (at least, this part is consistent! :slight_smile: )
If I then put the speaker on, I could hear them and they could hear me again.
IOW, with speaker off and no earphone plugged in, no phone communication in either direction.

Does this make any sense to anybody?

Both problems went away after a full power off / power on sequence.
Go figure…
Anyway, problem solved!

2 Likes

Hi,

In case it can help somebody else, I am adding here my experience with a different smartphone (Sony XA2).

I guess I had a similar “issue” (although I did not tried with the wired earphones).
The workaroud I found: in the settings of the SMS app, I changed the sound of the notification, from “Default notification sound” to another one. Since then, no more silence when I receive a SMS.

Regards

Ah, so I’m not the only owner of a haunted /e/OS FP3! :wink:
Thanks for the additional information.
When this happened to my phone, my message notification was already non-default…
I’m suspecting what triggered the problem was the plugging / unplugging of the wired earphones during an ongoing call, but I’m not sure yet - still experimenting to see if I can reproduce…

ah ok. So it is not really the same issue…
From my side, I stopped checking after having seen that the workaroud was successful, let’s keep it here if anybody else looks for a similar issue

Update: Problem is still there.
It recurs once in a while and I haven’t found an obvious triggering conditions yet, except that the problem always occurs after using the wired earphones (and subsequently unplugging them).
But I have found a new confirmation clue:
In “Settings / System / Status bar / System icons”, I set “Headset” to ON.
So now, whenever I plug my wired earphones, I can see a small headset icon on the status bar. And when I unplug the earphones, the headset icon goes away… at least most of the times.
When the problem occurs, that icon sticks, whether the earphones are plugged in or not…
So the problem is, at some point, the FP3 “thinks” the earphones are still plugged in, even when they are not anymore. And then on, it behaves consistently with that erroneous status, resulting in the problems I initially described: it sends outgoing sounds to the earphones, even when they are not plugged anymore, resulting in no sound when I take an incoming call without earphones, and no sound when a notification occurs.
Plugging and unplugging repeatedly does not change the icon nor the FP3 misbehavior with the sound.
Like previously reported, the only workaround I have found so far is to power cycle the FP3…
At the next power on, the problem is gone.

If someone could remove the “[CLOSED]” indication in the title, that would be nice. Thank you! :slight_smile:

ok, so it was a totally different issue in my case (the headset icon was always shown and hidden correctly when plugging or unplagging headphones)

I have this exact problem, have you solved in these past months?

Hi Sirvoe,
No, not really: See https://gitlab.e.foundation/e/backlog/-/issues/1869
for the gory details. The issue is still open at this point.
But OTOH, I have clearly noticed that the problem occurs much more often using the Fairphone brand earphones than when using another set of earphones.

1 Like

Thanks for the tip.
I had a very faint SMS notification sound, which could not get adjusted in volume.
Now i changed to another sound and now i can hear it :slight_smile:

The reason may technically be the same as for some other users above: i have tested wireless earphones which i later gave to my daughter.