[SOLVED] Signal notifications (without MicroG) don't work since the 4.59.? version

Hi everybody,

Since the 4.59.? Signal update of early May the persistent notification that keeps Signal running in the background isn’t there. It doesn’t matter if I reinstall the app, it will show the notification and after a reboot gone again.

So I only get Signal notification when I turn on my phone because Signal wakes up at boot but after this moment, nothing.

I could download the last working version (4.58.5) available in the website but I wouldn’t be able to restore my backup.

I guess a lot of people are experiencing this issue so I create a topic.

I’m on /e/ Oreo, and it’s not an /e/ issue because the last update was on April, 16th.

1 Like

Have you tried contacting the support team and reporting the issue and ask for older apk download ?

On Signal 4.58.5 here. Originally got the apk months ago direct from their website and its auto updated itself to this version thus far. No update to 4.59.8 pushed to me yet, still getting notifications at present. Using grapheneOS to note (so no microg). If I do recall correctly I read somewhere the signal dev is going to move it all to gcm push soon??

same issue here. Additionally my I had to re-register several times in the last weeks… don’t know why.

1 Like

Is that help ?

(/settings /applications / Langis or Signal / /notifications /disable other)

Oh yes I forgot this thing. A message telling my number phone has been used to register somewhere else and I needed to reconnect.

Sadly it’s not that easy :slight_smile:

1 Like

Here is the issue on their Github to follow it :

Notifications works on my /e/ pie device
(microG disable in /settings /applications)
with Langis freshly installed

Langis (Signal name inverted) is a fork of Signal for Android system without Gapps installed, without microG installed

1 Like

Yes I can confirm this workaround/solution work and I have been able to restore my backup in Langis. Thanks for reminding me the existance of this app.

Yes, the solution works perfectly. Any news from Signal support about this issue ?

Since 2017 you can use Signal without Play Services. Please see here on github: Support for using Signal without Play Services from moxie0

Theres another comment on github from 2019: I cite a user greyson-signal from github:

Did you install/register with Google Play Services disabled? Whatever the state is during registration is the state it’ll stay. You can’t register without play services and then turn them on later to start using them.

The same is also stated on signal community from theBoatman Use GCM/FCM alternatives for notifications .

so… you don’t need to install a forked app. Try to use the direct download from signal.org, verify the sha256 fingerprint and install it. The app updates itself.

1 Like

Yes but the vesion on the website is too old to restore a backup so Langis is perfect. And updated quicker than the one available on the website.

Thank you for this thread. It’s better to wait with that update then. Actually, best option is probably to wait till the next update is ready.

in the github of Signal, some people said that version 4.59.10 solved the problem.
But I tested version 4.59.10 on my Pocophone and I still face the problem.

I installed Langis (version 4.59.10) for workaround, no more problem.

Yes but I don’t think it xas really the case.

Let’s wait the 4.60 version, it should solve this.

Same problem for me on 4.59.9 & 4.59.10

Don’t waste your time with workarounds. As is mentioned earlier. Use the version from the homepage. I use it for years and never had problems.

I tried downloading the apk using Windows, and then cmd, to see if the SHA256 matches. However, it didn’t:

CertUtil -hashfile Signal-website-universal-release-4.58.
5.apk SHA256
SHA256 hash of file Signal-website-universal-release-4.58.5.apk:
db c6 ff 70 6b 83 80 39 0a bd 46 1a d0 d9 cd f3 cb 54 d5 97 b1 d7 24 68 4b 86 88
54 50 eb e1 aa
CertUtil: -hashfile command completed successfully.
Wondering where the error comes from… Also, how do you check the hash on /e/?

I use MK Explorer (File Manager) and you can generate a hash of any file and compare it to the hash you copied.

Thanks, I tried MK after downloading the apk onto the phone. Under properties in MK I can only calculate SHA1, and it does not match.