[SOLVED] SwissCovid on FP2

I am using an FP2 with the latest /e/ release 0.16-20210416110816, and I am very happy with it. Unfortunately, since ever, the SwissCovid app does not work. If I try to activate tracing, it says:

17: API: Nearby.EXPOSURE_NOTIFICATION_API is not available on this device. Connection failed with: ConnectionResult{statusCode=CANCELED, resolution=null, message=null}

Any idea how I could make that API available? I read that on FP3 it works…

The microG Exposure Notification Framework / API is disabled by default in /e/ OS. (Don’t ask why - it’s a depressing story :frowning: ). You can enable it as follows:

  • Open Apps
  • Select Categories (second button from the left in the menu bar at the bottom of the screen)
  • Scroll Down and select ‘System Apps’
  • the only item there should be the ‘microG Exposure Notification version’
  • select ‘Install’

After the installation, in Settings | System | Advanced | MicroG, you should now see, juts below Location Modules,

Exposure Notifications

Next time you run SwissCovid, it should ask you if you want to enable Exposure Notifications.

Good luck!


Worked perfectly, thanks a lot!
I can well understand why it is disabled, but I do not understand why it has to be installed separately (and not just installed but disabled). But I am sure this has already been discussed extensively, and I won’t restart a discussion here :wink:
Anyway… if those that are looking for it pass by this thread, they find the solution. I guess that searching for “SwissCovid FP2” will link to here.

1 Like