[SOLVED] Using /e/ on a Fairphone 2


I’ve got two questions with the use of /e/ on a Fairphone2: but I do not know if it depends on /e/ or on the phone. I installed /e/ since I received the Fairphone2 many months ago, and I’m using the last updates.

1/ I still have to switch the light on when trying to shutdown the phone. It was a known bug on FairPhone, but it was apparently corrected in February.
This issue is fixed in the 19.02.1 releases of Fairphone OS and Fairphone Open.
Is there anything I can do to make this fix work with /e/ ?

2/ I just bought a second SIM card. Both cards are detected by the phone, but I apparently have to unlock them both when /e/ is loading. Since one card is for my work, I would like to disable it (not physically if possible) on evenings and week-ends, but I don’t know how. Is there any way to do it? Moreover, I don’t know how to set which card / phone number I use when phoning.

Could anyone help me?
Thank you,

1 Like

Hi @Lucie, for #1 there was an update from a Fairphone dev team member two days back which looks related to this issue. We should be adding the fix in the next build

1 Like

I’m using the unofficial pie build for FP2 and my phone shuts down correctly and I can disable any of the two sim cards.

1 Like

Thank you for your answers!
@Manoj, I will wait for this release (coming soon on our screens…), thanks a lot!
@ff2u, do you confirm that you could not disable the sim cards before you install this unofficial pie build? Have you got a menu to do that? May it be that I could not find it while it already appears with /e/ (but without the build)?
I read that this unofficial pie build was indicated by Manoj: is there any hope that this could be part of a “next” version of /e/? Due to the warning, I’m not sure I will try to install the build…

At least in the pie version it can be found at settings -> Network & internet -> SIM cards.
There you can individually enable and disable any SIM card.
And sorry, I can’t remember if that setting could be found on the Nougat version…

That setting is not in the Nougat FP2 build.
Great that you raise these points @Lucie. I also stumbled on these when I started using /e/.

1 Like

Happy new year everybody!
@Manoj : I wonder if you know when the “next build” is to come. I thought you meant something like a “next version” : I last upgraded /e/ on December the 25th, but for my part, I still have to switch the torch on in order to shut my fairphone down. Do you know whether this fix could be taken into account ?
ff2u and @cedricoola : thank you for your answers. I confirm that I can not find this option in my build, which is probably the “Nougat” one. At the time being, I simply do not use the second sim card. Do you know if there is a way to suggest such an improvement to the developers team (even if it is certainly not the most important one to add) ?

1 Like

You’ll find more information regarding this issue in Fairphone 2 (FP2) workaround
(btw.: you’ll find all Fairphone-topics by using this link (resp. tag)…: https://community.e.foundation/tags/fairphone)

Let me check with the dev team and get back on this.


I read this other post and followed the steps given at this page : the pie build was installed - all worked correctly. Is there anything to do with this post, such as add “Solved” to the title (is there a way to do such a thing ?) ?

Thank you all (@Manoj, @ff2u, and cedricoola) for your help since last November !


Done and thanks for the update @Lucie

That sounds very good and I’m happy to read it!
There’s just one thing I’m afraid I’ve to mention:
You now can disable a SIM card – but it just doesn’t help :slightly_frowning_face:.

Another thing that annoys me is that, even when it the SIM settings are set to send SMSs from SIM card 2, the SMS app sends them with SIM 1, unless I specifically change it to SIM card 2 within the app.

Can’t say for the stock app, but in “silence” app the default sim setting is used for new conversations and for existing conversations the last used sim is kept.

I’m trying Silence but can’t make it work.
When I start a new conversation with a contact of my address book, the text field says ‘No SIM card found’. I can start writing but the Send icon is not active and comes with a little lock.
(The app does not allow me screenshots, sorry)

That’s strange. I’ve never had a problem with Silence. Did you configure it as a default SMS app after installing it? Did you give all necessary rights to the app?

That’s a configurable setting. Per default it’s not allowed. You can change that in settings->Privacy->Screen Security

OK, I checked the Silence app a bit more (setting it as default app allows me to send out SMSs now, indeed): Silence has the same behaviour as the stock app: my Android setting are set to send via SIM 2, but still, for new conversations the Silence app uses SIM 1.

Good to know that Silence works now!
But the SIM problem is very weird. I cross-checked and still can’t reproduce your problem. I’ve just created a “Recently reated Test Contact” then changed SMS to default “CARD 2”
and Silence defaults to send via CARD 2: