[SOLVED] Wi-Fi broken after an update of pie-version


I was using a “pie” version of /e/ which properly worked (namely e-0.7-p-2020021240991-dev-FP2.zip). On Wednesday, I noticed a new version (e-0.7-p-2020022843132-dev-FP2.zip): but there was another one that was downloaded and that I did not have installed. It seems to me that it could be a version of February the 15th: but I can not find it in the list of pie version. I decided to install it before downloading the newest one, and went away.

A I came back, my phone was booting again and again (screen “Fairphone”, then “e with the ball”, then something like a screen to enter a pin code… and a reboot). The phone was quite hot. I shut it down and opened it so that it cooled down. Then I used TWRP to install e-0.7-p-2020022843132-dev-FP2.zip with adb sideload.

It was a bit strange as /e/ was loaded : it worked like a first install. I had to set some parameters… and lost my contact list (but not my apps!). Moreover, my Wi-Fi does not work anymore. When I try to enable it, the button comes back to “disable” after a few seconds.

I tried to get back to a previous pie version, flashed the phone with the latest version of TWRP and “Advanced Wipe”, installed the version of today (e-0.7-p-2020030644075-dev-FP2.zip)… but nothing changed. And I still have all my apps available!

Something strange: the MAC-address of the Wi-Fi card appears to be very unexpected, that is 02:00:00:00:00:00.

Is it possible that my Wi-Fi card was broken when the phone became warm ? Is there a way to do a check-up, or even a log indicating why the Wi-Fi automatically gets back to “Disable” ? Have you any idea of something I could try ?

Thanks for having read my problem,

Well, with that really strange mac it might be. But it could also be something broken with your data. If you have a backup of your old data (or if you don’t worry too much for the old data) you might also wipe your data partition or even do a format in twrp.
Then flash os again and check. You might even try to flash stock os then to check if mac is back to normal in this case.

I don’t have a backup of my old data. Even if it does not really matter, is there a way to do it now ? I guess it is under TWRP ? If the Wi-Fi works after the “format” and that I restore the data, is there a risk that it becomes broken again ?

I think I will try the “format” under TWRP…
Thank you,

You can use the “backup” function in twrp.
Be aware it does not backup /data/media. You can connect your phone to a PC via a usb data cable whole you’re in twrp. Then you can copy/data/media to your PC.

I’ve never experienced that problem. So I can’t say if it’s solvable or if it might return.

Reset options > Reset Wi-Fi, mobile & Bluetooth Maybe it helps.

1 Like

(Found under settings->system)

Unfortunately, I already tried it.

It worked! I lost this time setup, apps, and other configs : but my Wi-Fi card does not have this weird MAC-address anymore, and the connection works again.

I did not restore the back-up to avoid a renew of the problem. Actually, I saved the files on a computer (while under TWRP) before I “format”. This was a good idea since I had to format the SD card again when /e/ ran for the first time afterwards. And I manually copied the files back.

As a conclusion : it seems that it works again. I can close the subject as “Solved” (if someone knows how to do that). Thanks all !

1 Like

That’s marvelous!

You as OP should be able to edit the title of the topic and add [SOLVED] there.

Just a quick note: I had the same error and for me a combination of reseting the wifi and then simly rebooting the phone worked. (Fairphone 3)