Swedish buss/train ticket app suddenly not working

The app “se.skanetrafiken.washington” stopped working. It worked fine before but now it just crashes when you try to start it. I have not used it for some time (a week or more?) and I’m not sure if it was after the latest stable update of my Samsung Galaxy S9 that the problems started or if it has to do with something else. I’m almost certain that I used the app after the system update.

The things I tried to get it to work are as follows:

  1. Re-install app.
  2. Install from both E appstore and Aurora store.
  3. restart phone.
  4. Try different MicroG settings and location on/off etc.
  5. Tried downloading older versions from Aurora store.

Nothing has worked so far, the app just crashes immediately. Any ideas what could be causing it?

Had exactly the same with a Belgian banking app “com.bpb.mobilebanking.smartphone.prd” Only got it working once after the installation with Yalp, tried all you mention above after that, never got it working again.

Yes, I had the same issue with my banking app before the latest update. Turns out it was the older version of MicroG that was the culprit. This got me thinking and I tried turning off MicroG and starting the ticket app, it now starts fine but naturally without the (Google) maps function and it also complains here and there about missing Google framework but it works for what i need it for (buying tickets and using them).
The case was almost exactly the same before with the banking app, it would start and be usable while complaining about missing Google when MicroG was turned off but would not work at all with it turned on.

So my conclusion is that the update of MicroG fixed my banking app while crashing my ticket app. Sadly I need MicroG for other apps on my phone so now I’m more or less stuck between using these different apps.