Unable to install /e/ or TWRP on my Galaxy A20e

I use to have a Galaxy A3 running on eOS. It was my first install and worked well. Later I installed it on a friend’s FP2.
Now I would like to install it on my Galaxy A20e…

First I tried via fastboot, but I can’t have a fastboot connection, it keeps saying “waiting for any device”
Then I’m trying via TWRP :

  • hard OEM unlocking : Up+Down->plug in, then long Up, then reboot…
  • enable USB debug
  • Boot in hard downloading mode : Up+Down->plug in, then short Up
  • Flashing TWRP via Odin or via Heimdall, same result : it says it worked well, but impossible to boot in recover mode, it still says ; “recovery: Error validating footer”
    Then I’m stuck…
    I’ve tried older versions of TWRP, it still don’t work…

Anybody can help me ?

Official TWRP instructions says :

Flashing TWRP without first flashing a vbmeta image with verity disabled will render your device unable to boot


https://forum.xda-developers.com/t/a20e-root-kernel-twrp-and-custom-rom.4183683 give a link to a dm-verity disabler :

Merci !
Je teste ça…

Fastboot don’t work with Samsung devices, you have to use Heimdall or Odin.

I’m sorry, I don’t get how to flash those files via Heimdall or Odin…
It looks like files to flash via TWRP (whish I can’t install…) :frowning:
I tried by flashing a file “vbmeta.img” which was supposed to be Verity disabled, but it didn’t work… No boot…
Re-flashed the old one and it boots again…
Can’t find any tuto explaining how to use Disable_Dm-Verity_ForceEncrypt.zip with Eimdall.

This generation of Samsung devices is beyond my hands on experience, but seems extra secured by Samsung from all I read.

If an official TWRP is available for the device you would be good to go and just swap it with /e/ recovery.

Did you fully read the xda thread?

This unofficial build seems to want magisk to install as per that thread. If one would rather not do that it is always worth trying official guides even if it requires expert input (TWRP then might work but probably not offer some features; this would exclude the build becoming official).

If this fails you will have follow unofficial author’s guide and try with magisk, at your own judgement.

Here you can find instructions for another Samsung device,
But from the same generation of Samsung device.


1 Like

So I managed to flash TWRP with heimdall.
→ flashed the recovery + VBmeta at the same time, then reboot directly in recovery…

But now I’m stuck with the GSI problem…
I tried to flash the system.img from /e/OS GSI, but it went to bootloop.
I tried to flash Multidisabler-samsung-3.5, then system.img, but it went to bootloop.
I re-installed magix from recovery mode, worked well.
I tryed to install Lineage for A20e GSI. No problem during the install, wipe the cash, reboot… And never end the boot.
I retried the /e/OS GSI, but it still doesn’t work… Just enter in a bootloop…

I keep trying and let you know !

1 Like

So, so I succeeded installing Physwizz’s QwizzROM for a20e (a202)
I retried with LOS, adding Physwizz’z Kernel before the GSI and it worked !!!
I tried the same way with eOS GSI, but it didn’t work (boot loop)

It might work just flashing eOS system on a fonctional Los ?
I’ll keep trying.

Ok, so I’ve tryed many different combination to flash the GSI on a working lineage, but nothing works.
But I tried with diffrent OS which worked well… Most of them coming from here : Eureka Releases - Browse /Samsung/A20e/S at SourceForge.net
And after checking at them, et appears they all are embeded with what seem to be configuration stuff.

I’m not sure I could simply replace the system.img in one of those packs… I thing I’m completely out of my competences here, and I think I might turn from /e/ to a fonctional Lineage.

Thx to Eureka Team, who made an Unofficial Eos install for the A20e, I’ve succeded to install it a few weeks ago, and it works pretty well !
You can find it here : https://sourceforge.net/projects/eurekaroms/files/Samsung/A20e/S/eOS/


Just wondering, as I got a A20e
Did you install: e-1.10-s-20230406-UNOFFICIAL-a20e.zip
It seems to be only this one off build, or were there any update build in-between?

Oh forgot, can you use the 2nd rear mounted wide angle camera and is it any good, if so?
How is battery life?

Yes it’s the only one I found
Cameras and battery life works the same as with the original OS…

TWRP : https://eu.dl.twrp.me/a20e/
@sourceforge.net/projects/eurekaroms/files/Samsung/A20e : e-1.10-s-20230406-UNOFFICIAL-a20e.zip

Hello, I am trying to do the exact same thing: to install /e/ on a Samsung a20e using macOS.

I managed to unlock the bootloader and do a factory reset, but when using heimdal’s GUI (heimdal-frontend) to download various files/partitions, my phone will still boot Android. I have tried different things, without any effect, am I perhaps missing a step that uses magisk ? It seems some constructor rom will cancel any download I do on the phone. Could @Thieuma give more information on how he succeeded ?

Thank you.

There is a problem with Heimdall not working on some recent device, have a try using Odin3Windows or Odin4Linux or Thor or ThorGUI