Unclear about instructions "Unlock OEM"

This is about using the easy installer with a samsung s9+ . The device is compatible with the easy-installer Java software.

On the wizard page titled “Unlock OEM” there is a step named enable ‘OEM unlock’.

The instructions say:

Open Settings ( OK I understand this !)
Open Developer Options (OK I did this too !)

enable OEM unlock (OK this is where the instructions become confusing… I will cite them here, then explain why I am confused.)

"You’ll have to keep pressing ‘Power’ and ‘Home’ and ‘Volume Down’ until you reach ‘Download Mode’ once your device is off. When you’re ready accept ‘Factory Rest.’

Keep pressing simultaneously ‘Power’ and ‘Bixby’ and ‘Volume Down’ until a blue screen appears to access download mode

Accept Warning by pressing ‘Volume Up’

OK so here is what is confusing me.

  1. On Samsung 9+ they have done away with the (hard / real) Home button. In previous Samsung Galaxy models, the Home button was in the middle bottom of the device and it was a real button. But on Samsung Galaxy S9+ it is not there.

So when the instructions tell me to:
"… keep pressing ‘Power’ and ‘Home’ and ‘Volume Down’ …

I am not sure what to do. I tried pressing Power and Home and Bixby, which is a single button on the left of the device and proceeding from there, but the installation failed.

  1. The order of operations the instructions give is a little confusing at this point. Here they are again:

"You’ll have to keep pressing ‘Power’ and ‘Home’ and ‘Volume Down’ until you reach ‘Download Mode’ once your device is off. When you’re ready accept ‘Factory Rest.’

Keep pressing simultaneously ‘Power’ and ‘Bixby’ and ‘Volume Down’ until a blue screen appears to access download mode

So the instructions appear to be telling me this (this is my understanding):

“after you press ‘Developer Options’(step 2 of 3) then press and hold ‘Power’ and 'Home” (no Home button!!) and Volume Down’ until… “you reach Download mode once your device is off”.

That is confusing me.

It could mean :

"keep holding these buttons down. Your device will power off. Continue to hold them when your device is off and it will turn back on again and then you will see an option for ‘Factory Reset’. When you see that, then press the ‘Volume Up’ to accept ‘Factory Reset’.

So I have this set of actions I am to do sort of floating around in a disordered way and I am not sure how to order them, what I should expect to see as a result of doing them, and what I should do next when I see one of them.

Here are my guesses:

  1. Hold down 3 buttons at once. Possibly ‘Power’ ‘Bixby’ and ‘Volume Down’ or possibly ‘Power’ ‘Home’ and ‘Volume Down’ . I don’t have a ‘Home’ button to hold down.

  2. At some point I will see an option to enter (or I will automatically be in) 'Download Mode '. I am not sure how I will know I am in this mode. I am not sure if I will enter this mode before or after my device powers off. The instructions appear to say I will be in 'Download Mode" when my device is off, but I would think I am in no mode whatsoever when my device is off.

  3. At some I will see and option to accept "Factory Reset’. I dont’ know when that would be or what I would have done to get there.

My best guess is that , after pressing developer options (step 2 in the instructions) I should start pressing 'Power" and 'Bixby" (my only hard button) and ‘Volume Down’ all at once. I will then see my phone power down. I should continue to hold them. The phone will then power back up and I will see an option to ‘Factory Reset’. When I see that option, I should accept it by pressing 'Volume Up".

That is my best guess. Unfortunately, that results in failed installation (error log sent to e-foundation).

I know I wrote a huge post but I wanted to be as clear as I could be about what I was reading, what I was confused on, what I think I am being asked to do and what the results were.

Hopefully I didn’t make your eyes glaze over.

Thank you !

I will add that I get a little red text that says “only official released binaries are allowed to be flashed” on the Download screen and it indicates that OEM lock is ON. So this may be a factor but I followed the instructions to the letter I believe…

Hi @davidgrand, you are absolutely right. Galaxy S9+ does not have a HOME button (like earlier devices at the bottom of the case). Instead there is a Bixby button at the top left of the housing.

vol_bixby_power stock_oem_unlock
OEM Unlock must be enabled in the Android stockrom. Only when OEM unlock is visible and colored, you can think about continuing with the /e/asy installer.

My phone does not have the option to unlock the OEM; this option does not exist under Developer options or anywhere else !
I read an online article that said you can make it appear if you change the date forward by a month and do a few other things. I tried this but it didn’t have any effect.

Also, I noticed that in the section titled Enable Developer Mode (Part 2) the final instruction is to "Tap on Android debugging’ but my phone doesn’t have this option either, i,e, literally no such option !!

Here is the article whose instructions I followed in a failed attempt to get an OEM unlock option to appear:

Here is a newer article that seems to explain the issue. This is the most likely suspect why I am failing to install the e-foundation ROM.

I am no Android enthusiast but it seems to me that it’s telling me not to reboot for 7 days and the OEM lock will be released. I can confirm what the article states- something called KNOX is in effect on my phone and I have no “unlock OEM” button available.

Sorry! Forgot the link!!

hi @davidgrand thanks for sharing this feedback about the S9+ specific documentation. Will pass this on to the developer and have the wording updated on the easy-installer.

Hi Everyone!

Well I just thought I’d catch up anyone who’s interested in my progress.

After obtaining cell service, I have left the phone continously on from somewhere around Sept 15 to today, so quite a long time.

Unfortunately, the menu under Developer Options titled OEM Unlock never appeared. I have all the other menu options as screenshot in the post by SusieQ on Sept 14th, but the OEM Unlock option is still missing.

I bought this phone just for this project, so it’s a bit of a disappointment. Realistically, Samsung can change the rules of the game at any time in any way they see fit for any reason they see fit. That’s the reason I rarely join in projects like this- because no matter how brilliant and industrious the developer’s are, they’re stuck playing a game their opponent is free to redefine at any time.

Well that was quite a depressing thought ! LOL.

If it’s useful to the great devs here I will now post the relevant information found under About phone:

Model Number: SM-G965F

Phone Status: Official
One UI version 1.0
Android Version 9
Baseband version G965FXXU2CRLI
Kernel Version 4.9.59-15076275
#1 Mon Jan 7 13:46:15 KST 2019

Build Number PPR1.180610.001.G965FXXU2CSA2

SE for Android Status
Enforcing
SEPF_SM-G965F_9_0001
Mon Jan 07 13:24:13 2019

Knox Version
Knox 3.2.1
Knox API level 27
TIMA 4.0.0

Service Provide SW ver.
SAOMC_SM-G965F_OLE_XID_PP_0002
21b84ec4ad0d7ece
XID/XID,XID/XID

Security software version
MDF v3.1 Release 4
WLAN v1.0 Release 2
VPN PP-MOD v2.1 Release 2.0
ASKS v2.0.0 Release 180410
ADP v1.0 Reease 180525
FIPS BoringSSL v1.3
FIPS SKC v1.9
FIPS SCrypto v2.2
FIPS FMP v1.4
SMR Release Jan-2019 Release 1

Android Security Patch January 1, 2019

Hi, @davidgrand

witch version do you want to install ?
Official dev build oreo 8.1 ?
Unofficial build pie 9 ?
Unofficial build Q 10 ?

Witch tools do you want to use ?
Linux Heimdall ?
Windows Odin ?
Easy-installer ?

I was using the Java easy installer, but the blocking issue was I could never get the OEM Unlock option to appear on my phone. The backgrounder is that some of these phones (not clear to me which release dates) even though they’re the right model number do not have OEM Unlock option appear in the Developer screen and this is a hard requirement to install any version of /e/ :frowning_face:

Many solutions have been suggested and I have tried them all: fooling around with the calendar and leaving it plugged in for a week or more… unfortunately, no OEM Unlock menu option appears.

I am sure /e/ is a great thing and I wish I could install it but it appear to me at this time that it’s not going to work on this phone. This is the second phone I’ve purchased- the first one was the wrong model- so unless there’s something else I haven’t tried I am not going to be able to enjoy /e/ :frowning: