Uninstall TWRP app?

I needed to boot into recovery to format my SanDisk Extreme microSD, as it was the only way to get the card to be recognized by my device. While I was there, I accidentally installed the official TWRP app.
The app serves on purpose on my phone. Is it possible to uninstall it without factory resetting?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Guess you installed TWRP system app, and can’t uninstall using /e/, right ?

It’s quite simple to remove it :

  • reboot to TWRP (recovery)
  • go to Mount, mount system (having “Mount system partition read-only” unchecked)
  • go to Advanced, choose “Uninstall TWRP app”
  • swipe to confirm, reboot System

Then, if you downloaded and installed the full app, just uninstall it like others (long press).

That does seem simple but I feel like I’m missing a step. I’ve rebooted to recovery and selected Mount, unchecked everything except System (leaving read only unchecked), but when I back out and go to advanced I do not see an option to uninstall the app. The TWRP version is 3.2.3-0 if that’s significant, by the way.

On the Mount screen I notice that I only have Select Storage and Enable MTP/Disable MTP as well. Is that an issue?

You may have to mount System in addition to those mounted by default (Data & Cache on my testing device).

Buttons at bottom of Mount screen should not matter, as long as you store apps in internal memory (not SDCard).

3.2.3 is quite old, I tested using 3.5.2 … Maybe there may have been changes :wink:

You can also try using TWRP’s FileManager (having System mounted read/write), look into /system/app or /system/priv-app.

OK, serious problem now.
I found the apk in /system/priv-app and deleted it. Now I’ve got one of two responses after trying to reboot. Either I get the /e/ logo with the dot bouncing until the device powers down, and then reboots into recovery.

Tried a factory reset and the issue is persisting

You changed something on the OS side (in system), a factory reset in the Android world doesn’t touch that, it only deletes user data as well as Apps installed by the user and their data.

Wouldn’t TWRP let you install the App again?
Else you could try to reinstall the OS.

Yeah. Thinking I might have to, unless I can make a warranty claim. Luckily I kept my S9 as a backup phone. Can you direct me towards how to install on my S9+? I haven’t messed around with DIYing custom roms since CyanogenMod (and I mean CyanogenMod)

Easy installer beta … https://doc.e.foundation/easy-installer

Manual install … https://doc.e.foundation/devices/star2lte

Thank you. Hopefully I can make that work.
Ironic. I bought the eSolutions store phones so I wouldn’t have to do this kinda work!

Sorry about your problem :frowning:

I’m wondering why just deleting the TWRP app will cause a bootloop !
This method is listed in XDA, and I tried it myself on my testing device.
I’ll do it again to try to get any clue about what happened …

Did you try to reinstall the app from TWRP ?

Edit : just tried again to delete /system/priv-app/twrpapp : rebooted to system without problem.

We’re all good people! I was able to use the easy Installer to get my S9+ back to factory settings.
I don’t know if anyone from the /e/ team will see this, but bravo. Getting my phone back up and running was a snap (in every sense of the word). I thought best case scenario I would have to send my device back to /e/, and worst case scenario I had wasted 430 bucks. But I once again have a privacy focused, no frills smartphone operating without issue!

There are some quirks and gaps associated with using /e/, even with the Aurora Store, but I can make this a daily driver no problem!

1 Like