[UNOFFICIAL BUILD] Motorola Moto E 2015 LTE (surnia)

I checked, the APN settings are correct.

Also I tried both Three and Tesco SIM on my harpia with /e/ and they work (LTE connection).

It’s possible. When I did my last lot of builds (for release/tag v0.12-nougat) I didn’t make a release for surnia as I have been focussing my efforts on Sony devices. I hope to be doing a new build run soon (when the next nougat release /tag appears), and I will try and remember to include a surnia build too.

Update: I bought another Surnia, supposedly unlocked, but it does not connect to the Three network either, even on stock rom, so it’s not /e/ causing the problem.

Would be good to have an updated /e/ for it though! Thanks

@petefoth and @Pinback. I can build a Q-eOS version if you want to?
Or do you @petefoth want to build it yourself? Let me know…

I’m very interested in that! Can’t build myself…

I’ll wait for an answer of @petefoth

Is it possible to put nougat back on if I prefer it to Q ? It is running quite well…

1 Like

Please go ahead and build it. I’m waiting for Docker to be functional again before I start making builds, and I’ll concentrate on builds for Sony phones when it is

1 Like

A new up-to-date unofficial Q-build for Motorola Moto E 215 LTE
This is an untested build so make a backup first and share your experience please.

I flashed the updated version of this Q build (19 Nov 2020) provided by @itsclarence on the Moto E (2nd Gen) “surnia” and it is working well!

It didn’t change the SIM connection problems of the phone (which seems to be partially network locked in the UK), but the eOS looks more elegant than the nougat builds, with important enhancements.

1 Like

Here’s a new build based on the v1-q branch. It’s untested - I haven’t even flashed it on a device yet. As always, use at your own risk

Note that the version of microG installed does not include the Exposure Notifications API. The Exposure Notifications API can be installed from ‘Apps’, as described in this post

1 Like

The build works but it has some issues. These are the issues I have found so far.

  1. GPS does not work until the second boot. (Minor, but can still be annoying.)

  2. When switching microSD cards, the Media Scanner does not re-scan storage. I turned the phone off before inserting the new microSD card and powering the phone on, and it does detect the SD card. Perhaps I’ll try ejecting the microSD card and inserting the other one and see if it re-scans.

  3. Signing in with a Google Account works, but syncing seems to not function. Also YouTube did not work, as launching it just displays a loading spinner with a Google Account signed in.

Overall, I’m impressed. The ROM is fairly snappy, even on this low end device… but that’s probably due to the lack of Goshdamnit Play Services. :wink:

Here’s a new Q build, built from the v0.14.2-q tag (which should be the same as the v0.14-q release). It not been tested at all, so use at your own risk, and backup your device before flashing.

Please make sure you read the release notes, especially the ’ microG EN update’ section

GPS Bug from the last build is fixed.

Google sign in doesn’t work properly on YouTube still.

The SD card is glitched. The ROM makes it’s own folders (even duplicated), but folders that you personally put on the SD card are detected improperly as 0 byte “.bin” files. This is probably also why media scanner isn’t finding my music folders. The two music folders weren’t made by me. I have some of my music (non-copyright sounds) in the production folder for when I make videos.

The weather app is stuck on London, but the home screen widgets work properly.

The theme has issues in some areas with white text on a white background.

1 Like

FYI, I did not flash GApps. Those are there for when I flash a different ROM.

I may have more screenshots, but I can’t post more than 1 per post and I can’t post more than 3 times because I’m a “new” user.

Thanks for the reports. I’m sorry the build isn’t working perfectly :slight_smile:

I’m afraid I’m not in a position to investigate these as I don’t have access to this device for testing and debugging - that’s why this build is ‘Unofficial’.


I can’t help at all I’m afraid - I don’t use myGoogle account on any of my devices

Is your card formatted as portable storage or as extending the phone memory?

I had a quick look in the official issues list, and there are a couple of open issues that may be related:

Feel free to add comments there if you think they correspond to what you are seeing on your device.

Sorry - I don’t use the weather app.

Maybe this issue?

I think I’ve noticed this myself but I can’t reproduce it and I can’t find any obvious matches in te issues list. May be related to #2476 or #592?

According to the plan, this device is due to get an official release in week 9 (01 Mar – 05 Mar). History suggests that it may happen a week or two after that :slight_smile:

If there is a new release (e.g. v-0.15) before then, I’ll probably make another unofficial build, which may or may not fix some of these issues.

Thanks for the reply. I’ll wait until the next build, or the official build… whichever comes first, before I try the ROM again.

I never the format the microSD card as internal storage for use in only a single device. I use exFAT or FAT32 on all my microSD cards, that way they remain usable in other devices.


@petefoth : thanks a lot, I will try on my good old Moto E 2015 :wink:

Édith had a non-working ‘phone’ app. just right now with a looping ‘app always stops’ popup. I couldn’t stop the loop, had to switch off the device.
Clean install, OpenLauncher, settings OK, all worked fine since Tuesday, didn’t had to use the phone function (holidays). SMS, mail, WA audio and video calls were OK…
I will test further this evening.

The problem with the phone app is a known defect which was fixed in v0.15 (I think). The workaround, until you get a fix, is to install Simple Dialer (from Apps or F-Droid) and set it as the default phone app.

There is an official v0.16-q build available now at https://images.ecloud.global/dev/surnia/

Sadly, our household no longer has a functioning instance of this device: my wife’s started turning itself off automatically a few days ago - probably a hardware problem :slight_smile: Now she has a Sony Xperia Z3 - she decided she would put up with a bigger phone so that she could actually read what was on the screen :slight_smile: So now I’m building for that device too!

Thanks a lot.

Easy workaround, I flashed official eOS-q-0.16. (Open Keychain seems buggy…).

Anyway, thanks again for all your surnia-builds.

1 Like