Using MagicEarth with a 3rd party app

I am using a third party app that I installed from the e-store called Visorando, which is just a database of hiking trails. As part of this app, there is a button that used to open google maps and that would then navigate you to the start of the trail. This worked fine on my previous googled phone, but now with /e/, when I click on this button I get the error “No apps can perform this action”.

So, I am curious: Is this a bug with /e/ not setting MagicEarth as the default map program somehow? Or is this a problem with the 3rd party app that only will work with Google maps?

I’m happy to contact the developers of visorando, but it is not clear to me if this is their problem or not.

1 Like

Maybe they use a google maps specific link, understood only by google maps. When developing my own apps I use the link geo:0,0?q=lat,lng(label) and replace lat by the latitude, lng by the longitude, and label by the name I want to use for this point.

This type of link is understood by all the apps applications I tried, including MagicEarth. You could ask the developers the method they used to link to external apps.

Maybe the app is supposed to open the whole trail path in your maps app, not only the start point ? In this case I don’t think there is a standard and maybe they only worked on google maps compatibility.

The link just opens Google maps, and starts navigating to the point, so there is nothing special. I’ll mention your approach to the developers.

I was just thinking that maybe there was a way to set a default “maps” program in /e/, or maybe to convert a call to google maps so that it got redirected to MagicEarth.

I tried your app and it opens in on my phone.
I’m looking for a good hiking app so I installed and never used it. When trying your Visorando and clicking on start point it opens :slight_smile: