Week 16 : 2021: Development and Testing Updates

Can confirm the update went smoothly on my FP3.


Thanks for the update

Smooth OTA update on a3xelte. :smile: The start up, “There is an internal problem with your device. Please contact your manufacturer” remains, #2840.

Other than this thread, when people run into problems while OTA updating, where will they be discussed? As this is my first OTA on a device that sometimes doesn’t handle OTAs well, I would like to wait a week and observe before upgrading.

Smooth OTA for the S9 from 0.13 to 0.16 as well. One small thing noticed is the update message states ‘your system is being updated to /e/OS 0.13’ (see below) where this must be 0.16. Don’t know if that’s only in the Dutch translation though. Many thanks for the update!

1 Like

In my eyes there is no translation error or a wrong display (/e/OS 0.13 - 15 apr. 2021), but your S9 ‘starlte’ works with the /e/OS ‘stable’ edition - and it still runs with e-0.13-o ~ 'O’reo (Android 8.0.0) thus not with eOS ‘Q’ (Android 10).

Only /e/OS build : dev currently works with eOS ‘Q’ e-0.16-q-20210415110657-dev-starlte. While I’ve an S9, it hasn’t been running /e/OS 'O’reo 8.0.0 for a long time, so I can’t check it on the device. After your review, let me know if I’m right or wrong with an assessment, please.

I was actually using the dev build. Flashed my phone based on Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10. This is the first time I’ve received an OTA for this. So now my system updater shows the version below.

I rec’d notice of the 0.16 dev build for the S9 today as well. I downloaded but it will need to be installed manually since this device has a TWRP recovery partition. Anyone happen to know which folder the 0.16 /e/OS zip was downloaded to (while searching in TWRP)?

I’m traveling this week and I won’t try performing a manual install until I get home :wink:

Galaxy S9+ ‘star2lte’

  • /e/OS ‘Q’ build 2021.04.15 : dev (Android 10)

1 Like

Hi Manoj & everybody

I have a Samsung Galaxy S4 Mini (International LTE) running “serranoltexx” 0.13
No update since [e-0.13-n-2020121089402-dev-serranoltexx.zip]
I have just seen an recent opened issue : “Build in failure for serranoltexx” on gitlab:

I wonder if I can help solve this issue ?
I am quite a newbie, but I can help if I am well managed. I rooted and installed my ROM by myself 2 years ago.

Thanks and Bye

I’m writing this message from my Yoga Tab 3 (YT-X703F), freshly updated to 0.16 Pie :blush:

Thanks to /e/ team ! :clap:

@mcmd I have TWRP too on an S9 and was able to update without any extra/manual steps. I’d just try it and see what happens for you.

I’m going to check later if the stock calendar app still has the bug of too many notifications.

1 Like

Upgrade failed for me on Sony z5c currently on 0.15 Q. This is my first time attempting an upgrade, so it’s possibly something I’m doing wrong.

Two things I didn’t understand, the update was for 0.16 but the “Apply update” screen said “you are about to upgrade to 0.15”. And the other thing was " this feature requires a compatible recovery or updates will have to be installed manually" - I don’t know what this means or how to go about ensuring I have a compatible recovery.

Hi @mike_from_ireland
I’ve just raised an issue in gitlab about this #3014 OTA Update fails to install. The workaround is as follows:

  1. Manually reboot into TWRP
  2. Choose ‘Install’
  3. Navigate to the directory `/data/lineageos-updates/
  4. Select the downloaded zip file in that directory
  5. Proceed with the installation

Hope that helps!


Thanks @petefoth I’ll give that a shot.

@cornfarmer Indeed it worked, thanks! Just as a FYI for anyone else reading this, if your S9 is encrypted and has TWRP loaded, when TWRP loads it will ask for a password- just hit “cancel” and the update will proceed.


Confirmation on my part that the Samsung A3 update to the e-0.19 version went well using a TWRP recovery to flash the new zip file. No problems apart from the Android error message that existed before.

However, the update on my main device - a OnePlus 6 - was much longer than expected. After the initial download there was a progress bar indicating the installation was taking place, but after a second message about “preparing packages” or something to that effect a further progress bar advanced at a snail’s pace and took well over an hour to complete. As there was no reboot to recovery and this is an A/B device I assume that the installation as to the alternative slot and then I was finally able to reboot successfully to the updated version.

However, as I have related separately, this new installation replaces my TWRP recovery with /e/'s own version and unroots the phone. This made a reinstallation of Magisk a major undertaking. See my post.

@petefoth that worked perfectly, thanks.

As always, thanks /e/ team

I installed 0.16-q-20210415110667-dev-star2lte OTA on my Galaxy S9+

First thing I noticed was (like others) root was gone, reinstalled via SIDELOAD Magisk again since DATA is encrypted.

Any way to decrypt DATA? I don’t have a password or a way to get password?

Another observation is that the phone app now has more options like Call Waiting disable which I can disable notification and it doesn’t put call on hold, but I prefer having working call waiting. It also has Call Forwarding menu which was missing. What it doesn’t do is follow the theme (DARK) so it’s white and very obnoxious when everything else is black/dark on my phone.

Hi @petefoth I have seen this issue being raised in a few devices after a OTA release. Any idea why this happens…were you able to check on the z3c …are we missing some files in our build system.