Why suddenly Apps app crashes with DAVx5 update?

All is in the title.
this morning the Apps app crashes with DAVx5 update (3.3.0->3.3.1). I have no other update for testing.
Yesterday and before all was OK.
I don’t understand.


P.S. I’m with a S9+ from e.foundation store and 0.11-o-2020083170820-stable-star2Ite

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Here is happening the same on Davx5 and also on updating StreetComplete, Samsung S8 SM950F

Same here Nexus 5x

I had an update today for Twitter an everything went well. I think the pbm comes from I installed DAVx5 with Aurora (or F-Droid) instead of Apps.

Here TrackerControl was added among those to be updated, and with it Apps keeps on crashing. F-Droid says that all my apps are updated.

Same behaviour (Apps crashing on TrackerControl, StreetComp!ete and Davx5) on tablet Samsung S2

This morning, on the phone no apps to be updated, and on tablet everything worked as expected.

seems the issue is with the DAVx package in the apps store. With apps no issue updating signal. Install F-Droid uodate DAVx

Since I installed DAVx and Apps told me I had updates, Apps would crash when trying to update. Other symptom included no Internet access, even though I had working WIFI and Mobile data.

Upon uninstalling the DAVx app, updates to other apps worked without issue, and Internet access is working.

I’m using a SM-G900T with /e/OS 0.10-2020080666687