Will /e/ include Corona exposure notification API and if so: when?

Which phone/OS?
What’s your experience so far?

This sound great - please let me know, how did you upgrade microG manually.

Hi @frank.bxl,
I gather from your “About me” that you describe themselves as technically adept. So it will not be difficult for you to upgrade manually.

I could not test my workaround on a Fairphone 3. Which devices should the microG Upgarde be for?

It’s for the FP3 - and it’s not rooted (for banking apps sake)

If anybody finds a way to upgrade it manually on the FP3, I’d happily switch back to /e/ from stock ROM, which I am (unhappily) using at the moment.

to verify my workaround I will release the first version of e-0.9-p-20200530-UNOFFICIAL-hero2lte and write down another workaround for me step by step. If it works as before, I invite you to try it as well. Save your most important data already once. Safety first …


Thanks. Is it relevant that FP3 is an A/B device or is your approach independent of this?

I don’t store much personal information on stock ROM anyway, but thanks for the advice :wink:

No! Temporary rooting with MagisK is however necessary because the microG components are system apps.

1 Like

Well, I have unexpected difficulties with the build. The /e/Browser fails and the installation of microG Services Core as well.



I will now try it again on another device with a different 9-pie build.

Hi …
my microG-upgrade-method from yesterday I cannot verify today. I have tried three /e/ OS 9-pie ROM.

Only the NanoDroid method works on the Galaxy S5 ‘klte’ with the current build e-0.12-p-2020093076095-dev-klte just like here with the build e-0.11-p.

Belgian Coronalert App works on different Android phones, but as other /e/ users have noticed, ‘NanoDroid method’ doesn’t work with the /e/ OS FP3.


I did it flashing the Nanodroid microg .zip file from TWRP, and deleting cache/dalvik. It seem to work ok for me until now. Do you know the Nanodroid microg .zip package?

Thanks a lot for your effort.
I guess I will have to stick with stock ROM for the time being :frowning:

Another successful test …

  • without rooting the device
  • without NanoDroid patch
  • only tool: TWRP Recovery

and a WLAN / Wifi online connection to the WWW is required. And of course some time to complete the individual steps.

Starting point is /e/ OS 9-Pie TestROM for Galaxy S4 ‘jfltexx’: e-0.11-p-2020082569744-test-jfltexx by eOS


Dutch Coronamelder

"The apps is active"


Dutch Coronamelder | UK NHS Covid-19 | Belgian Coronalert

The apps are active.


Actually the update is easy to do if you know how. There are many single steps necessary, but no special Android or technical knowledge is required. The phone is not rooted (Magisk), no external tool (NanaDroid) is used - only TWRP Recovery is in use.

See also:

1 Like

Thanks for this.

The problem is that I already tried to follow the instructions you linked.
Unfortunately, I didn’t find the path

on my FP3 (A/B device). At the moment I can’t test it, as I have no /e/ for the time being.

I do not really understand. My link ‘See also’ points directly to the comment from @marcdw /e/ support. His text summarizes the procedure in a short and concise manner.

I had to insert several additional steps to make sure that the exchange from microG Services Core version to v0.2.12.203315 worked correctly. For example the simple replace of the file /system/priv-app/GmsCore/GmsCore.apk resulted in a system boot loop.

Well, on the FP3 I simply didn’t have the path /system/system/priv-app/GmsCore

Or it was present and I didn’t find it. On the FP3 TWRP normally isn’t installed but booted from the PC, maybe that is the problem here? But anyway, unfortunately I can’t test it. Maybe the other person with FP3 here which still has /e/ installed could have a look whether the path is present?

1 Like

With the ADB commando adb shell pm list packages -f shows all installed packages | apps. With a PC editor like Notepad++ you can use the search function to find files or fragments, e.g.:


1 Like

So Maybe you are refering to me … I am not sure :smiley:
However, I could look for this directory in the /e/ system on my FP3 earliest tomorrow as I need my Computer with ADB. I have no technical know how but I will just do as @SuzieQ suggested:

1 Like

Hey guys, a current version of the SDK platform tool «adb & fastboot» belongs as basic equipment on every computer that wants to connect to an Android smartphone - no matter if Linux, Mac or Windows is used.

1 Like