Wired earphone working erraticaly in applications

Hi there!
I have a Fairphone 3 running /e/OS 0.9-2020060957753.

I just bought a brand new earphone with volume control. The controls work fine on phone calls (volume up/down, hang-up) but they work erraticaly in other applications as Telegram, Signal, Spotify, Podcast.

I’ve tested the earphones on an iPhone 8 and they work fine.

Is it h/w? Is it s/w?

Thank you,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi guys…

Could anyone adise here?
Is it a /e/OS problem?
Is it a Fairphone problem?


Is it an /e/ Fairphone, or did you install yourself? If you installed yourself, try to update your software.
EDIT: I see you use stable channel… The dev channel is ahead a bit, and maybe this problem is already solved and not yet implemented in stable channel. @Manoj can you check?

1 Like

I have the same issue on youtube and phone calls (but it doesn’t bother me).
0.9-2020061158052; /e/ intsalled by myself

It’s an /e/ FP3.

Hi @edotmq was this FP3 purchased from /e/ and on the latest stable build

Yes, it was purchased from /e/ a month ago with whatever version on it, I’ve done 1 upgrade to the latest on June 10.

Hi there…
Any updates?

@Manoj when do you expect the stable update comes online? Would it solve this issue?

The stable channels should get an update this coming week.

Thank you guys… …

Hi there.

Still not working…

Pl can you share the build details on your FP3

Still not working.

A usb-c headphone plugged in the usb-c port works, but a p2 jack headphone in the p2 hole doesn’t. The p2 headphone works well in other devices, so it’s not the headphone…
I’m getting frustrated at this stage. After 3 upgrades and not working yet, not to mention other applications not working either:

  • Insight Timer, when I try to login it hangs;
  • Android auto, doesn’t connect to the car
  • CA mobile authenticator, doesn’t generate passcode

While I appreciate FairPhone’s green initiative and /e/ Foundation for the deGoogled OS, I really do, things need to mature and improve yet on the workability.

For me the last straw was CA authenticator, as I need it for work now, and had to revive my old iPhone for that? Outrageous.

So I ask you guys, where are the flaws: FP3 phone? /e/OS build? Both combined?

Which one should I put aside for a while, in order to have a fully functional mobile? Even if not away from Google’s goggles…

Thank yous,

Aurora Store (alternative access to free-of-charge Google Play Store Apps) lists all these 3 Apps as GSF-dependent, which means they need Google services.

/e/ has no Google services. /e/ uses microG to mimic Google services as good as it can, but that has its limits.
While it works for a lot of Apps, there is no guarantee, and even if it works at a particular time, changes on Google’s side can break that at any given time, until microG did the necessary catching up again.

If you are really dependent on those Apps working 100%, /e/ is not the right OS for you, not now, and not in the foreseeable future.
You would need to use either the stock Fairphone OS, or the upcoming LineageOS with something like Open GApps (the real Google services in installable form) as well as a device registration for using Google services on a Custom ROM if you use a Google account and don’t want to endanger it.

Thank you for your answer AnotherElk. I understand what you’re saying. What I didn’t count was how difficult is to get really away from Google.

As I said, CA authenticator is a work- related need which is out of my control, as the customer uses it (and the customer is always right). The others don’t bother much, but the headphones… Looks pretty basic! And I’m not diminishing development work. It’s only me having the issue? Is it the OS or the phone?

Re: CA authenticator, what’s the alternative? Engage with CA for a deGoogled version? Is that an option at a large among software providers?
Re: LineageOS, is it deGoogled as well? How does it compare to eOS on privacy/security?

Thank you again,

You can find more informations here.

The headphones on p2 jack are not working yet. Any perspective on having this fixed!

Just to make sure I understand you correctly: Are you talking about a headphone on the 3,5mm jack not working at all or just the volume buttons? For me the headphone works, but the buttons not.
In a quick search I couldn’t find a headphone-button related issue on gitlab, so I guess, nobody is woking on fixing this. If you need this, I guess you should create an issue…