Wired earphone working erraticaly in applications

That’s correct, the volume buttons don’t work.
I thought Manoj was was working on it, as per previous emails in this thread.

I assumed the issue was created with the first email on this thread (Wired earphone working erraticaly in applications) and that it is still open as not fixed yet.

Can you please clarify whether is there someone working on it?


Could somebody from /e/ support team answer my questions?

  • Is there an open ticket for my issue?
  • Is there anybody working on it?

Hi @edotmq,

sorry for the huge delay…

Actually the only way for us to follow an issue in through the gitlab by opening an issue.

Anyway, we should have been much more reactive and guide you more so sorry again.

Now that I have a Fairphone 3 with /e/OS pre-installed and earphones with jack and buttons control, I will test if I am also facing what you are facing and come back to you ASAP.


Thank you Anonyme…

I first tried with an app that doesn’t need any authentication because it’s easier : NewPipe (an open-source YouTube client, available in the /e/ Apps installer).

I can successfully increase or decrease the volume and pause/play the video/music.

Could you tell me if it works or not for you before further testing please ?

No, it doesn’t work.

You said the buttons of the earphone are working on other phones, but are other earphones with buttons working with your Fairphone 3 ?

Yes, that’s correct. I have an earphone which plugs into the mini USB port, and all controls work fine: volume up/next song/fwd, volume down/previous song/rew, pause/play/hangup.
The other which plugs into the 3,5mm jack, none of the controls work, but it works on iPhone.

Ideally it would be nice to test with another Jack earphone, to only change 1 factor and easily isolate where the issue comes from.

If another Jack earphone (ideally of different brand than yours) works, you know the issue comes from your earphone.
If another brand of earphone with Jack doesn’t work, the issue is more likely hardware.

Personnally I used Samsung earphone (that came in the box with a J3 2016) to test. If you could also test with Samsung earphone and NewPipe, it would be perfect and we would directly know where the problem is.

It makes sense.
I don’t have other jack earphones, so I’ll try to get into a shop in the coming days where I can try a few - hopefully the Samsung as well.

to reiterate: you have audible output at all times. With “erratically” do you mean the controls do not work within the same application at all times, or do work in one application reliably and in others not at all?

I have earplugs with vol.-controls, and e.g. vol up/down works globally, middle button (three button control) pause worked in the 3 mediaplayers I use (standard Music, VLC, SicMu) - other functions can depend on the current view (must be list iterable, like a playlist/album) - for example double tap on center only skips to next song depending on the view.

It must be software dependant problem if the controls work in some capacity.

The Apple EarBuds’ with plug controls do not work for me at all (see this post) while cheap AKG earplugs do, the latter probably are according to android spec

Edit: Can you share the manufacturer/model of your headphone?

Hi there.
@Anonyme I went out to a shop so I could try different earphones without buying them, but there was not much available for testing due covid, but I managed to test 2, one Sony and one Goji and they didn’t work either.
@tcecyk the brand is Betron, no nexpensive. I just plugged them in in order to be note precise about the erratic behaviour, and what was my surprise to notice they are working fine! In Spotify, NewPipe, Radiodroid, and phone calls!
I don’t know what happened, I’ve tested Nee Pipe just a few days ago and was not working… The only thing was me getting other earphones plugged in, but they didn’t work either, so I left it!

I’m happy its working but would like to understand… anyone?


Hi !

Happy to hear it is now working.

No idea why it now works though.

I appreciated all the help and engagement from you guys, and I’m really happy it’s working BUT I reckon /e/ would like to know what it was? Whether hardware or software? Cause an issue doesn’t just vanish, does it?

Thanks again.

Sometimes it does without knowing why, and that’s fine. We have to focus on issues that are still existing.