Advanced Privacy turned off and still wrong GPS position on FP4

Bonjour,
personnellement, j’ai réglé le problème en modifiant les paramètres d’Advanced Privacy (selon fcayre)
J’ai essayé la méthode de Stanwood mais sans succès.

  • List item

paramètres : Advanced Privacy → Gérer ma position → Utiliser ma localisation réelle.

Je perds l’intérêt de cette sécurité mais j’ai retrouvé mon GPS. :slightly_smiling_face:

Automatic translation
Good morning,
Personally, I solved the problem by changing the settings of Advanced Privacy (according to fcayre)
I tried Stanwood’s method but without success.

  • List item

settings: Advanced Privacy → Manage my position → Use my actual location.

I lose interest in this security but I found my GPS. :slightly_smiling_face:

1 Like

Followed the steps above, didnt’t work. GPS was still way off.
After enabling advanced privacy and setting GPS to real location everything works fine. If I disable advanced privacy again, GPS is wrong again.

My steps:
Deactivating working profile
Deleting cache of apps
Enabling Advanced Privacy with real GPS location

1 Like

On FP3, swap to top left screen and switch off “Advanced Privacy”? It generate a fake random position.
Or go in the options and enable the real position.

No additional steps, sorry. Maybe this bug has more than one cause :confused:

I have changed the location and now the GPS doesn’t work. I tried deleting the cache of the app (Organic maps), disabling Advanced privacy, changing to fake position and back to the real one. It cannot find the location. Itis just loading to infinity. I’m on FP4 and on 1.0 stable.
Is there a bug report already on the GitLab?

Did you tried the possible solution on post n°9?

Often, deactivate + reactivate “location” does solve this issue…

So, here is the workaround: cycle through tes gps masquerade settings, so after a couple of minutes it will find the actual gps position. When I go to sleep, the next morning I need to repeat this workaround and every time I loose the gps.

Interesting fact: it always points on Manila.

I am not satisfied with this and don’t see this as a solution! This is only a workaround. Please make an update to fix this!

I have now for a few days suddenly the same problem.
My location is simply no longer displayed, even when Advanced Privacy is off. I have a FP4 and the system is up to date.

Hi, same kind of issue here.
I have a FP4 on version e-1.1-r-20220628200015-dev-FP4.
I have turned on Advance Privacy false location, and after that, even when deactivate it completly, no apps can have my location. It is as if the whole GPS unit was not functionning at all.
I try turn on and off the location. Enable the real one on Advance Privacy, exclude apps from it, disable Advance Privacy, but nothing worked.
Is there a fix for the future ?

Best regards,
Gerhunt

I have the same issue with my Fairphone 3+
MagicEarth or OSMand+ doesn’t find the GPS location after AdvancedPrivacy desactivation…

e_FP3-userdebug 10 QQ3A.200805.001 eng.root.20220705.091059 dev-keys,stable-release

Still true on 1.1-q-20220708202053-dev-FP3 (not a newer version than 220705 stable, dev build came later than stable this time).

Hi, I have the same problem on FP3.

e_FP3-userdebug 10 QQ3A.200805.001 eng.root.20220705.091059 dev-keys,stable-release

In my case however when I open the Advanced Privacy app it automatically switches to the “Use dummy location” choice and afterwards if I choose “use real location” instead it crashes and closes.
If I reopen the advanced privacy app, it opens for a moment and crashes again.
To reset the real location I am forced to reboot the phone several times, in effect proceeding by trial and error. I have microg disabled, can this be related to the bug? What is the location service in use? On my previous gs290 phone (if I remember correctly) it was Mozilla location service. On FP3 I cannot find this setting/info. Thanks for the help!

Edit: i can’t disable only the position setting, if I try, app crashes.