Asus - Zenfone Max Pro M1 (beta) - X00TD - Documentation Suggestions

Please add your suggestions to improve the documentation for the Asus - Zenfone Max Pro M1 (beta) - X00TD here …

Please help me I can not use after upgrading to version / e /e/0.15 , I am using version 0.13 with google apps , but when upgrading to version 0.15 generates several errors with google services, and I can no longer use.

Hi, this is a documentation suggestions area and your request for help may not be answered.

Please ask your question again in this area
/e/ Devices >> Asus >> support

Press this link open “+ New Topic” and you will find a place to ask for help, perhaps check this post first.

Good Luck :smile:


Can you include the link to the latest TWRP recovery to use, or at least its version number? The one provided is twrp-3.2.3-0-X00TD-20180814.img and did not work with me till now. It’s 2 days that I am struggling to install “e” OS on my max Pro M1.


Hi @ashish welcome. You have replied to me, so I will answer! :slight_smile:

As above, this is a Documentation Suggestions thread. Do you have a solution to your TWRP issue?

If yes, this is the place to document your discovery as accurately as possible with useful links to your TWRP version and/or solution.

If no, please use the link in the post immediately above yours to:

a) search for other links of the type e-devices >> Asus >> support

b) ask for help.

Bon chance


I managed to install and use eelo. Here are the steps.

  1. Login to device and update to Pie.

    This will update device drivers.

  2. Start Developer Options

  3. Login to recovery.

  4. Format disk and remove cache

.5. Use adb to copy e OS zip archive on external SD card.

  1. Use “adb to install”. Sideload didn’t work for me. I flashed from the external SD card via recovery.

That’s it!


And first of all, thanks for the documentation!

I am currently stuck at the step “Unlocking the bootloader” : when I follow the steps on Asus’ “support site”, there is no “Unlock boot loader” available for download for the Zenfone Max Pro M1 :

Or did I miss something?

The 2 download links of this page ( point to the same download page.
Where is it possible to download the file “recoveryfilename.img” noted in the “Installing a custom recovery” section ?
Thanks for your help.

This is “general” problem for all or many recent builds is reported on in Week 40, 2023 : Development and Testing Updates, in other posts and again Week 40, 2023 : Development and Testing Updates - #26 by Manoj

New method to unlock the bootloader:

1 Like

With your link, MexIT, I resumed the installation on the Zenfone, and succeeded, this time.
Thanks a lot!

Here I share some comments on the process.

  1. the method with official APK did not work for me (I could download the APK, but an “unknown error” window displayed after I accepted the EULA and the last disclaimer)

  2. the method with the unofficial APK worked perfectly.
    Nota bene:

  • there is no need to download the unlock.rar file: all there is to do is executing the code
  • the slot instructions are useless and can be removed
  1. after I successfully unlocked the bootloader (thanks again!), I resumed the install for /e/OS from the line “Installing a custom recovery using fastboot” :

  2. when I reached the step about the sideload under “Install /e/OS”, it first failed, with the following error : assert failed: asus.verify_modem("2019-09-03 16:24:00") == "1"
    In order to solve this problem, I followed the advice I found here :
    I unzipped the file, went to the file META-INF/com/google/android/updater-script ; changed the value of asus.verify_modem("2019-11-2512:49:03") to “0” and zipped back the folder.

  3. I tried again the command adb sideload
    First, I had a warning (Signature Verification failed) because of the modification of the zip, but I accepted to continue, and the process went to an end with success : on the phone, there was written Script suceeded : result was 1.00000 (although on the computer, the process exited with a “total xfer 0.98x”, instead of 1.00x), and the first start went perfectly well.

And now the phone is up and running!