Bootloop after installing V0.21 on preinstalled /e/ S9

Hello !

I bought a Samsung Galaxy S9 from the /e/ shop with /e/ preinstalled.
I always kept my smartphone up-to-date, I had the 0.20 version until yesterday and every update worked perfectly until this one.

I saw the notification for an update to version 0.21. Download thru the settings app worked fine. Then, the phone installed the update (via TWRP, without any error message). Then it reboots in a loop.

The problem : I have the “Galaxy S9+, powered by Android” screen (by the way is this normal ? I have a S9, not an S9+). After a few seconds, it switches to the /e/ logo with the jumping dot. The /e/ logo stays here for one minute, then there is a black screen during 1 second and again the “Galaxy S9+, powered by Android” screen. This happen in a loop and it never boots correctly.

What can I do ? As /e/ was preinstalled I hoped not to have any problems with updates… I don’t have a backup phone so it would be really cool if someone could help me.

Thanks in advance


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

If you are saying “I previously had Oreo stable /e/0.20 but I was offered the Android Q version Upgrade” this would be a serious failure of OTA Upgrade.

Also, you say, “Galaxy S9 from the /e/ shop with /e/ preinstalled” in which case please ask for guidance at

I’m saying exactly that !

Thanks for the email address, I just sent a mail.

1 Like

I received an answer from the helpdesk but it didn’t solve my problem. I’m waiting for their next e-mail but in the meantime I was wondering if someone knows which steps are in the second point of this tutorial (the toturial is not complete) : [HOWTO] The system doesn't boot (bootloop)

Other question before doing anything wrong : could a factory reset from TWRP solve my bootloop problem ?


Yes, but You will loose the advantage of this specific data looseless upgrade

Little update on my problem :

I managed to copy the important data of the internal storage on my SD card via TWRP :grin:

After backing up the data, I tried to factory reset the phone via TWRP (as suggested in this HOWTO, solution 3). It didn’t work, my phone is still in bootloop.

I tried all solutions listed in the HOWTO except the last one (as I’m not very confident with reinstalling the OS from the computer), and nothing worked.

I’m still waiting for an answer of the helpdesk…

What should I do ? I don’t have a functioning phone since 5 days, and it begins to be complicated for me :grimacing:

I don’t understand what caused the problem, I only accepted the /e/ upgrade to Android 10 I was offered. And I don’t know what to do now…

I would be very grateful if someone could help me.

Thanks in advance and thanks to everyone who already helped me

As the factory reset already wipe your /data,
And you need a working phone

Why not trying to install the downloaded /e/ or latest /e/ from the device ?
(What OS do you use on your PC ?)
Do you know if your phone is still on Oreo or now on Q ?

Thanks for your answer !

The problem happened directly after the upgrade from Oreo to Q

How can I do that ? Do I need to flash /e/ with my computer ?

The already downloaded /e/builds are on your device in the directory

Step (8) is installation without computer (if you don’t have computer to download, you can download with another phone and use a SDcard).

Thanks !

So I restored the data backup I did with TWRP to have the already downloaded /e/ builds (in /data/lineageos_updates).

I reinstalled /e/ 0.21 as explained, I did not have error messages but I’m still in a bootloop.

I tried to reinstall older /e/ versions that worked fine before (0.20 and 0.19) but I have an Error: 7 message.

May my 0.21 zip file be corrupted or so ? I tried to download a fresh /e/ 0.21 file but I did not find it (there is only the dev version).

the 0.21 OTA upgrade to Q, has been removed, only filename was stable,
it partialy fails : you are here !

if you want to stay in the stable branch, you need to install (vendor part of the Oreo system) before installing

Installing /e/ Oreo on some devices that embeded android 10 based Samsung firmware, installation can fail if vendors part is not coherent with /e/ system part.
In this case, please:

  • Download those vendors
  • Install them
    • On the device, go into Advanced > ADB Sideload, then swipe to begin sideload
    • From the computer, please run adb sideload <vendors file>

it can also be done on the device using TWRP install feature

I think I read (but I cannot find it again) that the e-0.21q-xxx-stable was not yet published.

The error 7 messages might happen if you had tried to install Oreo, but the phone was at least partly configured as Android 10.

You do not have to stick with stable, so you could download dev, trying say I hope that might perhaps work.

While the ROM might be corrupted, maybe something prevented the phone from receiving the Upgrade correctly - I do not know the method of Upgrade, so it is unhelpful for me to speculate further on this.

I hope that the /e/ team is trying to figure the most risk free way to get you out of this. Only if you felt you had to continue without that support I would think that you would have to prepare to take this path Revert Samsung Device to stock ROM on Windows PC then a “start from fresh” install of /e/ using a Q dev ROM as above.

Hello !

Thank you for your precious help ! I’m sorry to answer a bit late but I installed before reinstalling /e/ 0.20 today and… IT WORKED !!!

My phone is now fully functional, thank you !

After booting the phone, I there was a “system update” notification to upgrade to /e/ 0.21. I tried to upgrade but the same problem happened : bootloop ! So I reinstalled /e/ 0.20.

This is quite annoying… I’m stuck to /e/ 0.20 now… I suppose that I will have the same problem for future versions :frowning:

I think it’s a bad thing that you have to deal with this kind of problem when you buy a phone with the system pre-installed. Everything should work properly, the software has to be stable and functional. I really like the work that the /e/ developers are doing but it’s this kind of problem that prevents me from recommending /e/ to people around me :grimacing:

Anyway… Do I need to do future updates ? It’s quite risky, isn’t it ?

Other question : if I encrypt my phone, can I still access my date via TWRP ? (can TWRP decrypt the content of the phone ?)

Thanks again for all your help and responsiveness !

1 Like

Hello !

I noticed a big problem after reinstalling /e/ 0.20 (Android 8) on my S9 : the SIM card is not recognized anymore…

Do you have any ideas ?

Thanks in advance

Do I need to do future updates ? It’s quite risky, isn’t it ?

In fact, this should have been a “one off” as you could check by following some of the threads sharing this tag ota-upgrade. Many users had a successful experience, except perhaps a dozen of you covered in the list above. I think you are saying that you took the path of “going back” to Oreo - in which case, it would look as if you tried again (by upgrading to 0.21, Q, Android 10) to do the failing Upgrade.

There is no news that I have seen on the optimum fix.

SIM card is not recognized

is mentioned in this thread: SIM not detected SM-G960F after OTA Upgrade.

A on the subject of Samsung + encryption might suggest it was best avoided without expert guidance!

Ok, so I won’t encryp my phone :sweat_smile:

Thanks for your help ! From what I have seen on the forum there is actually no solutions to both problems :

  • Being able to boot correctly on Android 10 (/e/ 0.21) on my S9 (bootloop)
  • Recognizing a SIM card on Android 8 (/e/ 0.20) on my S9

Are there other things I can try to do to try to solve any of these problems? I don’t really know what to do now…

Is the /e/ developers team aware of this issue ? As you said, it is a serious failure of OTA upgrade

what to do now…

Watch and wait, I think.

The way that developers are made aware of these issues is when someone tells them. We do this in this way, (new users might possibly face a login issue which is fixed by sending exact details of the failing login to

Following the link I gave you above, takes you to the issue raised there

If you add to that please be careful to show where your situation is the same, but particularly where it is different (in that I think you downgraded to Oreo).

You will know that you can demonstrate whether you have “Oreo | Q” and also “stable | dev” from

Settings > About phone > Android version > /e/ version.

It is reported by others that this does not work on every Samsung, but if you long press on /e/ version you should be able to “Copy to clipboard”

To stay up to date, read posts like OS Upgrade - S9 / S9+ found under development-updates and follow the posts in hashtag ota-upgrade