Bricked samsung Galaxy S9

Hello everybody,

Due to work, I recently had to quickly remove /e/OS and reinstall Android on my Samsung S9. In fact I’m using a vpn app : « NetIQ Advanced Authentification » which doesn’t work on /e/OS.

So I backed up my data, and I tried to flash my Galaxy, but I made an error during the process and I bricked it. Fine… This was on July 29th at 10pm.

So now, when I turn on my Samsung S9, a green screen appear and asked me to use smart-switch recovery opyion, and only the download mode is usable.
(I have a picture of my phone characteristics if needed)

Using ODIN I tried to install the last version of OneUI (for galaxy S9) on my devices : Fristly, ODIN sees the device > flash begin > and few seconds before the beginning of the execution, the phone indicate that an error appear: “KERNEL REV. CHECK FAIL DEVICE:12, BINARY:12 (BOOT)”. I tried several times with different version on One UI, and despite the error I waited few hours.
(I have and picture of the error if needed)

So, without expectation, I tried the “Samsung Smart swich recovery” but without success (surely because my phone isn’t recognized as a Samsung phone). And finally, I have installed the command line ADB, and I tried “fast_boot_devices” to see if windows find my device, but nothing.

Right now, I’m out off ideas and out off skills. I clearly need helps, to get back my phone. Since then I bought “transition phone”.

Maybe an idea will be to reinstall a recovery mod to use a twrp…

To inform you here are some topics I used:

Cela veux dire que le firmware téléchargé n’est pas plus récent que celui déjà installé

Les commandes Fastboot ne fonctionnent pas pour les Samsung, il faut utiliser Heimdall

You can use Odin to flash a “combination firmware” to reset the bootloader version and then reflash the latest Samsung firmware