Canadian Samsung S5 Neo SM-G903W - stuck on boot screen

I might be way off here, but the clues I picked up were that often “just flashing the manufacturers ROM first” is the answer ( … to stuck on boot screen) … you have lots of people reporting difficulties … cannot quite specify the issue … you have multiple “original ROMs”.

How do you decide which ROM to flash in order to give you a “fresh start”?

I tried:

  • putting the zip on a sdcard and installing from sdcard → still stuck on boot screen
  • switching to another computer, another usb port, another cable → still stuck on boot screen
  • both old twrp/old zip version and new twrp/new zip → still stuck

I messaged robertson who seems to have gotten /e on his g903w. Will see if there is any help for my particular g903w’s there.

I have a SM-G903W. I’m from Canada.

I’m busy with work but did get /e/ working earlier. I used this build e_s5neolite-userdebug 9…eng.root.20201202170422 test-keys

I tried to upgrade the build but newer builds failed months ago when I could try.

One last note I had to wait at the first boot an exceptionally long time. I left my device and did it while a load of laundry washed and fed everyone.

Thanks for the post. I will give it a try if I can find that build.

Do you have a link for it?

e-0.xx-q-20201202170422 is no more on the e.site

https://images.ecloud.global/dev/s5neolte/

https://doc.e.foundation/devices/s5neolte

In some desesperate case,
Flash back to stock firmware and starting from scratch could solve install problems

Download Samsung firmware

.

Flash Samsung Firmware ( Windows / Odin )

.

Flash Samsung Firmware ( Linux-MacOS / Heimdall-Frontend )

.

Flash Samsung Firmware ( Linux-MacOS / Heimdall-command )

.

[HOWTO] install /e/ on a compatible Samsung Galaxy Device

Could anyone in /e send me a link to this old version e-0.xx-q-20201202170422?

I would rather have the G903W running an old version of /e, than not running at all.

Thank you

This was to highlight that it took an exceptionally long time at one of the boot screens. I let it be for about 15 minutes at least but likely an hour while it seemed to hang or be doing something.

The build wasn’t supposed to be the point. It was included as I did have other builds not work though. Unfortunately I don’t. I just looked up the Build from the settings on my device. The repo was linked to from this forum. I found the thread by searching for s5neo " or something like that. Don’t remember much more.

(One other thing I find Odin to be much more reliable to install a custom recovery. I can’t recall if you got your recovery working

I will try again and wait an hour of just seeing the Samsung Galaxy S5 Neo screen.

To me, the build might be a potential avenue to pursue.

TWRP old and new seemed to work (able to reboot, able to issue adb sideload command, able to install zip on sdcard). I could also try installing with Odin.

Will keep this post updated when I have time to test those things.

Thanks @greg.weber for your ideas.

I encourage you trying to install lineageos to be sure /e/ is the problem and not your device.
( use their recovery) If it works try to install /e/ with it

You have to format /data, not wipe, when changing the OS to another build lignee, or changing android version grade.
then reboot to recovery and wipe /system,
Finally install the new OS and wipe /cache, and /dalvic-cache

I waited for a couple hours but it was still stuck on the Samsung Galaxy S5 neo boot screen. Nothing changed.

I did as suggested above. No change to stuck Samsung boot screen after an hour.

I installed Lineage recovery lineage-17.1-20210905-recovery-s5neolte.img using heimdall:

heimdall flash --RECOVERY …\lineage-17.1-20210905-recovery-s5neolte.img --no-reboot

And then in Lineage Recovery, installed lineage-17.1-20210905-nightly-s5neolte-signed.zip from SDCard. I couldn’t see any wiping data options in Lineage Recovery, so I didn’t do any. —> seemingly stuck Samsung boot screen.

I could try again to see if Lineage would boot, if someone knows how to wipe the appropriate partitions using the Lineage recovery.

Edit: I did find the format ability in Lineage recovery via Factory Reset: format system, cache, data. Now try install from sdcard. → reboot → waiting on stuck Samsung boot screen to see if it will progress at some point (I’m not going to wait more than an hour)

Don’t wait more than 2 minutes on the Samsung logo…

Waiting 5 or 20 minutes only make sense if you see the / e / logo bouncing animation !

.

image

.

Could you flash back to latest Samsung firmware using Odin on a windows PC ?
( or having a Heimdall firmware package ? )
( or create one with TWRP embeded ? so, no need to boot on Samsung OS ! )

I think this is the solution. I just talked to someone who successfully flashed G903W with LineageOS. He looked at my situation and said that I had to flash it with the highest Samsung stock firmware.

He said that I needed that version’s baseband before I could install a custom ROM on that phone.

When I get time and find the correct Samsung stock rom, I will give this a try.

What is your country ?

I’m in the Chinese-Communist run lands of Canada

So, 15 Canadian software variants for this same hardware, (enormous, in France we have max 5 different, general case is 3 per device).

BMC Canada (Bell-Internet)
BWA Canada (SaskTel)
CLN Canada (Clearnet)
ESK Canada (EastLink)
FMC Canada (Fido)
GLW Canada (Wind Mobile)
KDO Canada (Telus, Koodo, Rockhopper)
MCT Canada (Mobilicity)
MTA Canada (MTA MTS, CTF Cityfone, TBT Tbaytel)
MTR Canada (Metro PCS)
PCM Canada (Bell-Internet)
PMB Canada (Public Mobile)
RWC Canada (Rogers)
SOL Canada (Bell-Internet)
SPC Canada (Telus, Rockhopper, Koodo)
TLS Canada (Telus)
VMC Canada (Bell-Internet)
VTR Canada (Video Tron)
XAC Canada (XAC carrier free)

G903W Factory Firmware XAC ( 4 files included userdata )

G903W Update Firmware XAC ( 1 file without userdata )