Canadian Samsung S5 Neo SM-G903W - stuck on boot screen

From stock Android 5.1.1, I installed TWRP, formatted data and cache/system, and then adb sideload e/f e-0.18-q firmware, then reboot into Recovery a couple times before rebooting into System.

Boot is stuck in the Samsung S5 Neo words - I have to remove the battery in order to power off. Even if I wait 10 minutes, it never gets to the bouncing /e logo.

I tried older versions e-0.16-q but it still gives the same stuck boot screen result.

I tried itsclarence unofficial e-0.17-r and it gives a different result: the Samsung S5 Neo words come up for a few seconds and then the phone powers itself off.

I restored with boot/data/system of Android 5.1.1 backup via TWRP to return to the stock firmware.

Any ideas on getting this Canadian SM-G903W flashed with /e?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

… but if ****W==Canadian, … I think …

Yes, W does seem to mean Canadian.

Models after the Samsung S7 SM-G930W8 appear to not be able to unlock the bootloader or whatever technical incompatibility is caused. So yes, G965W won’t work.

However, supposedly people have gotten /e working on their G903W.

I’m wondering why it doesn’t boot up on my G903W?

I am wrong, this seems indeed to be an Exynos device.

I found this , Flashing G903W with G903F ROMs | XDA Forums

… and I see very many “carrier” ROMs for it here: Download Samsung Galaxy S5 neo SM-G903W firmware - could that be the issue?

I loaded cpu-z on the Samsung S5 Neo G903W and it shows Exynos 7580.

Yeah, that XDA link that you gave doesn’t seem to be promising.

I’m not sure about the carrier ROMs being an issue. But not sure.

I did see a /e forum post where a G903W user said an unofficial /e was working for them. I tried the unofficial ROM but it still didn’t boot up.

I could either be doing something wrong/missing a step, or perhaps no one really has gotten /e to work on their G903W.

s5neolte is the right device codename,

Heimdall :

Odin :

have you tried the first build from @Unknown or another tested as working in the thread
[UNOFFICIAL BUILD] Samsung Galaxy S5 Neo (s5neolte)

and is is listed here Info about s5neolte | LineageOS Wiki

1 Like

I loaded the TWRP 3.3.1 as suggested, format data, cache, system, then adb sideload as suggested.

Reboot into Recovery and then reboot System → still stuck on Samsung boot screen :frowning:

In case : do you reboot to recovery after format the /data partition as recommended ?

ok: I wiped data, cache and system and then reboot to recovery. then adb sideload and reboot to recovery. then reboot to system
→ still stuck on Samsung boot screen

Adb sideload may be buggy or the cable,

Have you tried the install using TWRP from SDcard or Internal storage (copy the e.ZIP only after wipe)

I might be way off here, but the clues I picked up were that often “just flashing the manufacturers ROM first” is the answer ( … to stuck on boot screen) … you have lots of people reporting difficulties … cannot quite specify the issue … you have multiple “original ROMs”.

How do you decide which ROM to flash in order to give you a “fresh start”?

I tried:

  • putting the zip on a sdcard and installing from sdcard → still stuck on boot screen
  • switching to another computer, another usb port, another cable → still stuck on boot screen
  • both old twrp/old zip version and new twrp/new zip → still stuck

I messaged robertson who seems to have gotten /e on his g903w. Will see if there is any help for my particular g903w’s there.

I have a SM-G903W. I’m from Canada.

I’m busy with work but did get /e/ working earlier. I used this build e_s5neolite-userdebug 9…eng.root.20201202170422 test-keys

I tried to upgrade the build but newer builds failed months ago when I could try.

One last note I had to wait at the first boot an exceptionally long time. I left my device and did it while a load of laundry washed and fed everyone.

Thanks for the post. I will give it a try if I can find that build.

Do you have a link for it?

e-0.xx-q-20201202170422 is no more on the

In some desesperate case,
Flash back to stock firmware and starting from scratch could solve install problems

Download Samsung firmware


Flash Samsung Firmware ( Windows / Odin )


Flash Samsung Firmware ( Linux-MacOS / Heimdall-Frontend )


Flash Samsung Firmware ( Linux-MacOS / Heimdall-command )


[HOWTO] install /e/ on a compatible Samsung Galaxy Device

Could anyone in /e send me a link to this old version e-0.xx-q-20201202170422?

I would rather have the G903W running an old version of /e, than not running at all.

Thank you

This was to highlight that it took an exceptionally long time at one of the boot screens. I let it be for about 15 minutes at least but likely an hour while it seemed to hang or be doing something.

The build wasn’t supposed to be the point. It was included as I did have other builds not work though. Unfortunately I don’t. I just looked up the Build from the settings on my device. The repo was linked to from this forum. I found the thread by searching for s5neo " or something like that. Don’t remember much more.

(One other thing I find Odin to be much more reliable to install a custom recovery. I can’t recall if you got your recovery working